Import .las or .e57 not scaling correctly regardless of what template I select?

This is very frustrating and if it isn’t a matter of user error it is something that is a drastic issue with this feature of SU Studio:

My first step in my workflow is managing the point cloud in CloudCompare, which is a unitless system that simply reads the data as x,y,z coordinates. A utility transmission tower I’m working on should be approximately ~120.0’ FT, from the top of the concrete foundations the tower is sitting on to the top of the tower.

If I chose the Urban Planning, Meters template: the tower comes in at ~120m, okay, so naturally I think I should then use the Urban Panning, Feet template: NOPE, now it’s almost 400’ ft!!!

Please, please, PLEASE tell me I’m doing something wrong here. I can’t imagine I’m the only one having this issue if this is a SU/Scan Essentials issue.

However, regardless of what template I am importing into, SketchUp/ScanEssentials is bringing it in as if that is 120’ meters.

no idea how the scans work, but I know how the templates do.

changing template has nothing to do with it. if you draw a 1m cube in a meter template, it’ll be the same as a 1000mm cube in a mm template. same when you import stuff, your import appeared as about 120m, 120m is about 400ft and that’s what you got in the feet template.

you should either check if during the import steps, you can force a specific unit, or rescale.

for the first one, I’ll use the DWG import as an analogy. When importing a DWG, you either import it “as is” or you can force a scale. SU will read the dwg as beign drawn in “units”. on recent DWG, the file tells SU what these “units” are, and auto import will give you the proper scale.
On older DWG, it won’t. and you might import a DWG drawn in mm as m (and get a file 1000 times too big). The solution is to force the import unit

I guess there could be a similar step, your file is supposed to be 120ft tall and it gets imported as 120m. Either the file is wrong (ie it has the right dimension but the wrong unit?), or the import tool is forcing meters (maybe you can force feet instead).

Last solution is immediate scaling. import, then using the tape tool you rescale it. in your case, using the tape, press ctrl to stop guidelines creation, mesure a dimension you know, and type the correct value. it should resize your whole file.

Since I’ve never used scan essential, Can’t help you further.

I get that, but you’re misunderstanding what I’m saying:

When I open a template in feet, it comes in at almost 400’ ft (3.2x bigger than thought), but when I open a template in meters and import it, it comes in at 120m. It should be 120’ ft.

This isn’t an option.

Also not an option: the referenced point cloud doesn’t scale when you do this, only the drawing entities created in the .skp file.

lol, then why the heck are you even trying to provide solutions???

about 400 ft equals about 120 m. I don’t know about the internal structure of point cloud files, but clearly either the embedded unit info in the file, if it exists, is wrong, or, the point cloud extension interprets all units as meters. All point clouds that I have met have used standard units (meters) so I have not seen this problem. @Jacques could perhaps tell us about how units are interpreted.

Import your point cloud into SketchUp. Draw a line from the highest point to the base (or whatever is 120’). Use the Tape Measure Tool, starting at one end of the line ending at the other. Once you click on the end of the line, enter 120’. The prompt will ask if you want to resize the model. Select yes.

In correct, this scaling function does NOT effect point clouds being referenced. It will only scale the drawing entities of the .skp file. So my models will scale down, but the point cloud will stay the same.

You’ll be scaling your model to match the point cloud. You could do this in a separate file. Use the line as a ‘yard stick’ using copy and paste into other model files to keep things consistent.

It’s definitely assuming the units of the point cloud is in meters, but what’s driving me crazy is when I then select a metric template (or even specify them in drawing properties) it doesn’t then correct the issue.

I can perform a universal scaling in Cloud Compare and then import it, but this is a big file/area (approximately 80 million points) and in order to get the best results I’ve had to segment various attributes into separate .las files. Not only would scaling everything in cloud compare be tediously annoying, it would cause me to question the accuracies and if I’m not confident in those I’ll be a deer in headlights when I deliver to the customer.

I would never do that: scale my model to be knowingly incorrect when I have to deliver to a client?! No way.

If you send me the .las I’ll show you how to correctly scale it.

I know HOW to scale a drawing/model, I’m saying I have zero intentions of knowingly scaling my models by 3.2x to match a point cloud reference when I have stringent accuracy tolerances I have to adhere to. Especially when this seems like something that shouldn’t be an issue, considering how long the industry has been using these types of datasets.

You can scale the Su model to match.

Can you upload the point cloud to a cloud service and post a link to it?

Maybe upload the file before and after you edited it with Cloud Compare.

Unfortunately I can’t share any of the datasets due to the nature and this project being public infrastructure.

I don’t know if the point cloud is affected if you scale your whole model, but you could try this workaround:

  • import the point cloud
  • draw an 1 meter line
  • select the Tape Measure tool and measure the 1 meter line
  • type 1’ and press Enter
  • click OK to the box that asks if you want to scale the entire model

I’m pretty sure you cannot scale a point cloud.

It isn’t. Others have suggested a similar solution. The referenced point cloud file or .rwp project isn’t affected by the tape measure scaling method, only drawing entities in the .skp file.

What format is the original point cloud? Maybe download a free 14 trial of Undet and try importing with that plugin?

Free Trial - register and get Undet for SketchUp | Undet

A nice thing about scaling your model is that the point clouds, SU models, surveys, DWGs, meshes, topography, will match.

Screenshot 2023-07-11 143728
Screenshot 2023-07-11 143743

I already used up an Undet trial license on this PC. It was okay.