Import is taking forever (Please help)

Every time I attempt to import my vehicle .dae file from Blender into SketchUp, the import loading gets stuck on 50% for a while. I just bought this Desktop 3 months ago. How do I fix it where it can load my .dae file without stalling for a long time?

What version of SketchUp are you using? Your profile is unclear. How big is the .dae file? Share the file so we can take a look at it and see what we get.

1 Like

How big is it?

SketchUp 2017. I sent the file through as a .dae Google Drive file to your DM on here.

The files is 122 Mb! It’s no wonder it’s taking awhile to import. You might try importing it without merging faces and without the validity check. Then the importer will have less to do.

1 Like

With Validity Check and Face Merge turned off it imported in less than 60 seconds. There’s so much excess geometry however CleanUp 3 reports more than 80 hours to clean it up.

Clean up the source file or let SketchUp do it.

As I type this it’s up to about 90 hours. I can’t leave my computer tied up for almost four days fixing your model, though.

1 Like