Trouble importing .dae

Hi, we’ve been given a .dae model to use from an Architect and we cannot get it to import. I’ve tried a lot of the options I’ve seen on the forum (open in blender and resave, use blender cleanup options, and delete portions of the model in blender and resave) and asked the architect to reduce the file size as much as they could. Can anyone help or give me other options to try? The file is too large to upload so I’ve put a dropbox link below.

I’m trying it now straight into SketchUp - but at almost 400mb , things are gonna get messy real slow.

That is going to take an age to import and when it is there, it will be hard to work with.

~ 10 million edges

Mikhai.s Yes, I assumed it was still quite a large file. I’m planning to cut out everything but the section we need in order to make it more workable, but couldn’t even get it to open on anything but blender and blender made the file even larger. Can you share the skp file so I can try to reduce size by cutting it up in sketchup? Or is there something you did differently to get it to open?

The file does import into SketchUp - but it takes a long time to import.
I could barely even select anything!

I’m trying to do a few things to make it more managable

What application is the file coming from?

Unfortunately I do not know for sure. I believe they use Archicad, but don’t know for sure that’s what this model is.

If they use Archicad, they can export their model directly to SketchUp. Many users don’t know that, as it requires doing a “Save as…” from an Archicad 3D view. It also enables the user to clip out the bits in the model that the recipient doesn’t need

Still trying to get something useable - I think you’ve been set up to fail with this one.

Huge site of multiple buildings modelled down to fixtures and fittings - heck I’ve just watched it load in 40 shirts into a fitting room :smiley:

@Elmtec-Adam We re-asked for them to reduce file size and finally got something that we could open. Chopped about 3/4 of that model out and have something that is reasonably workable. I appreciate the help, but I think we’ve got it settled enough. I agree with you about the detail of their model…it’s a little bit crazy.

I left it running overnight in a few tools have and I managed to get this, everything I tried to use it with hated it :laughing:
My laptop is not happy with me now.

Some bits of geometry didn’t make it through - but you may be able to make use ot it - especially if you have some more.

also @mihai.s , how did you get what you did, I only managed to get a straight DAE import to work once and it was entirely loose geometry.

Hi Adam,

I tested two working methods:

  • varianta A
    -1 minute - importing the .dae file in pCon.planner;
    -5 minutes - exported as skp (SU2017 - 1.16 GB);
    -3 minutes - opened it in SketchUp 2022 (325 MB);
    -Then I started to group the raw geometry into elements, using ‘CLF Loose to Groups’, and assigning tags that I then turned them off one by one, to work more easily;
    -And then I was going to use CleanUp to remove all the extra diagonals and edges from each group, individually.

  • varianta B
    -1 minute - importing the .dae file into Blender;
    -I used an addon to clean the dae model (tris to quads, remove doubles, etc…);
    -In Edit mode - L (select linked geometry), P (separate selection) - creating objects (groups), then export as .obj with ‘Object groups’.
    -Then imported into SketchUp with each group separately, going to assign tags for visibility and easier use.

Both require time and I just wanted to check and learn how could I arrange and clean up such a model.

Thanks for letting me know what you tried.
I tried a few things in Blender, but I couldn’t get any Hierachy to persist and I didn’t want to “parent to empty” manually across 24k objects - I’ll have a look at what you did there.

Was it bmesh clean you used?

I ended up using Speckle to move from Blender to Revit and then importing the RVT into SU.
Specke is super cool actually, but it took an age to load so many entities and with SU it was just “working” for hours without any sign of life, so not really practical at such a scale

You’re welcome, Adam!

I only tested for about half an hour (including the import of the .dae file), it remains to look for addons for Blender that automatically group/separate each element and test them.
And in SketchUp, as I tested, it will probably work, but it requires a lot of time.
Or maybe I will find another option.

addon DAE Clean

But the modeling of the ‘Maritime Youth House’ is more interesting and there is still a lot of work. :wink:

Amazing! thankyou kind sir.
I come across this stuff quite often with many large customers, but this one was perhaps the most demanding one I’ve ever seen, so I’m keen to push the limits of what can be done.

Cu plăcere! :slightly_smiling_face:

I’ll let you know if and when I find an addon for Blender that automatically groups and separates geometry. Or if I have any other ideas on how to improve the way of working for the two variants or a new one.

I’m after one that takes any identical objects and replaces them with a single instance - without needing to manually select them.
I’ve experimented with this in SketchUp and Ruby, but never got anything reliable enough.

Good thing you reminded me, one of the steps in SketchUp, after grouping and cleaning the geometry was to use s4u to components to convert the identical groups into a single component.

That sounds like what I would do with selection toys - I’m guessing them must share the same entityID (as groups) with that S4U one too?

I used two cubes and tested both extensions, Selection Toys creates one component and the other still group, and s4u only one component for both identical groups.

All four groups are identical, but they are not copies after one!