Taking an hour + to import a small model?

Has anyone had a hard time importing a small / medium sized sketchup model (8MB) into a very large model? (200MB)

Anyone found a way to speed up imports? or a workaround?

This can be kind of scary with deadlines looming. I have five or ten more of these to import,
and then I have to import the whole thing into a much larger model.

I do not typically see a slow down performing the kind of operation you are describing. Usually the import process is smooth, how long is it taking? 200mb is reasonably big, is that file already purged and optimized? Have you tried opening both files and using copy/paste to move geometry from one file to another?

Is the Outliner window open? if so, you might try closing it. Apparently, the Outliner window is very compute-intensive in some versions of SketchUp.

1 Like

What version of SketchUp are you using? Please complete your profile as that information can help us help you.

In the end it took several hours to finally complete. I faithfully click on the “Purge Unused” and “Fix Problems” buttons in the Model Info / Statistics panel. I haven’t tried good old Copy Paste. I usually either drag in the content from a folder or, in this latest case that took several hours, use the File / Import functionality.

It’s encouraging to hear that you don’t see these issues.
It’s been this way for so long in my case that I thought it was just a problem with the software.

TDahl - that’s a good point about the Outliner. I try to keep that out of my Default Tray when models get big for the very reasons you mention. Thanks for trying to help me figure this out. Are you able to complete imports into large models relatively smoothly?

Thanks DaveR. I just updated my profile. It was definitely out of date.

1 Like

I’m reloading an existing component - just a house - and Sketchup is locked for a very long time. I did notice that sometimes when I try to re-open a Sketchup model that I just finished working on I’ll find that Sketchup says, “This model is already in use - open read only?” If I open up Windows Task manager, I’ll find an instance of Sketchup running as a background process. If I kill this process I’m then able to open the model again. Perhaps at this point I should just jump to Technical support and submit a ticket? What do you think Dave?

This sounds more like you’re taxing your computer with it.

When you installed SketchUp did you right click on the installer and choose Run as administrator?

I’m pretty sure I did not set it up that way. (See attached pics of permissions for both shortcut and actual target.

I should also mention that my workstation is reasonably robust -
i7-7700K CPU @4.2GHz, 4 cores, running Windows 10 Pro. (10.0.17763 build 17763)
Twin GeForce GTX 1080 GPU’s, 32GB Ram, 176 GB Virtual Memory
Sketchup Pro 2020 (Version 20.1.235 64-bit)

That doesn’t answer the question about how you ran the downloaded installer, though.

Dave - Is there a way to find this out ? - it’s been a while since I installed it, and can’t rely on memory. When I see that the “Run as Administrator” box is unchecked by default, that makes me think that this might reflect on the permissions I set when I originally installed it. But if there is a better way to find this out - I’m all ears.

I want to help you get what you want - since you are generous enough to try to help me!

The simplest way to find out is to try again and make sure to do it right. If you right-click the installer (NOT the SketchUp app) and choose “run as administrator” from the menu, the choices you see may include “repair”. If so, choose that and let us know if things improve afterward. If you don’t see repair, just do the full install.

There isn’t a way to tell as far as I know. It’s sort of the thing you’d have to know that you did. Steve gave you good advice. If you need to, download the current installer again from sketchup.com/download/all and then right click on it and choose Run as administraor from the Context menu. If the option to Repair is presented, take it.

1 Like

will do

I have reinstalled Sketchup Pro (Version 20.1.235 64-bit), having right clicked on the installer and selected, “Run as Administrator.” (I completely uninstalled Sketchup first b/c the repair functionality wasn’t able to complete. I’ve also restarted Windows since the reinstall.) I am trying to import a small model (4MB) into the larger development (219MB) and so far, the behavior is still there. It’s been something like 1/2 hour now and I’m still waiting for the import to finish.

4 Mb is not a small SketchUp file and 219 Mb is already a pretty large file.

Right. My original assumption was that this was just regular Sketchup functionality - but then others on the forum suggested that they didn’t have this issue, so that gave me some hope.

The repair you did was a good thing even if it has no impact on the speed of adding the file. At this stage, however, I think the slowdown is just due to the file sizes and your computer processing power. Try this: Start a new blank file and import that 4 Mb file. How long does that take?