Import/Export in one coordinate system

I am a beginner at Make.
I am trying to import a mesh from a point cloud.
This works fine.
I have found out how to create a simple model around the mesh, snapping to points.
But if I try to export the model, it does not seem to be in the same coordinate system as the original mesh.
Is there a way in Make or Pro to export the model in the same coordinate space?
I am scanning to ptx, merging scan layers into a single coord system (Identity transform) still in ptx, then into MeshLab, and exporting to Sketchup, exporting the model in VRML so I can get hold of the coordinates to do some more calculations on the mesh relative to the model. But model and mesh are no longer in the same coordinate system.
(also,any ideas on how to get the colours of the mesh points/faces into Sketchup?)
Thanks in advance,

There are three kinds of coordinate objects in SketchUp.

Geom::Point3d - These are virtual (memory) objects used for calculating and creating geometry (including meshes) in a quicker way than if they were to be added into the model database first. (So you do the heavy stuff in memory first, then add it to the model when it is set up correctly.)

Sketchup::Vertex - These objects are a subclass of Sketchup::Entity, and therefore are model database objects. They represent the actual model coordinates that are shared by edges and faces. But because they are not subclasses of Sketchup::Drawingelement, they do not have a methods to assign a material (and hence a color) to them.

Sketchup::ConstructionPoint - These are special object that use stipple lines (not edges,) to mark 3D spots in the model. They are subclasses of Sketchup::Drawingelement, so they do have a method to assign a material (and then a color to that material.) But they also have a global “guide” color that is usually applied to cpoints and clines.

But faces and edges are subclasses of Sketchup::Drawingelement, so they do have a method to assign a material (and then a color to that material.) The default style, however, is likely set to display all edges with the same color (the global edge color, which is usually “black”.) You can change the current style’s edge color setting to “by Material” in the Edit tab of the Styles inspector dialog.
Window > Styles
Edit tab > Edge Settings (leftmost button, ie the wireframe cube)
… at the bottom you’ll see a Color: dropdown list. Change it from “All same” to “By material”.

Now you can assign materials to edges as well as faces.

Very often imports into SketchUp are wrapped within a Group or ComponentInstance. They are their own context, with their own transforms. If you can click the mesh once, and the whole thing hilites, then it is a group or component.

You can either double-click it to enter into it’s context and coordinate system, or right-click and choose explode from the context menu.