UV mapping for Photoshop (or for anything really...)

sketchup
photoshop

#1

I am a beginner at all of this so please bear with me. I am wanting to export an .OBJ from sketchup to be used in photoshop. My problem is all of the “UVs” or “Meshes” (In the red box, I think that’s what theyre called…) are grouped together randomly and with random names. I never actually made these groupings in Sketchup and I don’t know how to change them. This is just what the .OBJ looks like when I import it. As it stands, I can’t change the materials of individual surfaces in PS because they’re grouped together as meshes. How do I change this in Sketchup? Is this what people mean when they talk about UV mapping? If someone could point me to an appropriate tutorial in SU I’d really appreciate it.

Thanks,

AL


#2

Photoshop is not a full-featured 3D modeller.

Render engines usually work with one mesh per material. For that reasons many exporters export all faces of the same material grouped into a mesh.

A mesh is an object (or surface) of geometry (vertices =~ points) and the associated topology (how these vertices are connected and form facets/triangles; no edges). In a mesh, there are no distinct face entities that can be edited independently without affecting the mesh as a whole. That is why there exist 3D modellers: they represent facets as independently editable faces, and add edges for easier handling.

UVs are not related to meshes, but to the positioning of textures on facets and meshes. UVs are coordinates in the “UV” coordinate system (2D, conventionally used for textures), in contrast to the “XYZ” coordinate system (3D).

If you wanted a different structure of the OBJ file, you probably would have to write your own exporter (that maybe exports each face as its own mesh). SketchUp’s built-in OBJ exporter has some options (behind the options button in the export dialog), have you played around with them?


#3

Yea I’ve played around with them. People with 3Ds Max don’t seem to have a problem opening the files. I frankly can’t afford that program. I will keep experimenting. Thanks!


#4

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.