Import DWG - Autocad entities ignored (images) until SU2018


#1

Hi guys,

I usually import my 2d cad drawings of shop interiors to Sketchup for building the 3d model.
The 2d wall views usually contain images (xref of jpg, png).
Until recently any images in the 2d DWG files were ignored by Sketchup while importing the file. This was ok for me as I copy 3d furniture and visuals from my other projects. But since SU 2018 most of the images are imported too.

I can’t find any settings to turn this on or off , or at least keep some control. Because the images that are imported are often resized and covering each other and the 2d linework. Also still some images are ignored while others are imported, can’t figure out any criteria for this.

My workaround is to use SU 2017 for importing the DWG file and then build the model again in SU 2018.
Or ofcourse I could clean up the DWG file first and remove any images, but this is just adding another extra step.

Is there anyone that has any clue about this new feature, what makes an images suitable for import and is there any way to keep control, or turn it off, and prevent the resizing?

Erwin


#2

In SketchUp Pro 2018, you could use “selection toys” to only select the images, then delete them. It seems a lot easier than deleting the images individually.

My guess is that 2018 upgraded their DWG import functionality. Did you check the import options?


#3

Thank you, the plugin at least make things easier.
Yes I checked the import options menu, but it does not provide many options…

As another workaround I recently found that exploding an image in Autocad (lt 2018) replaces the image by an outline.

I guess until the import menu has improved we need the extra steps…


#4

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.