Trouble importing jpegs that are part of an AutoCad for Mac file

Admittedly I am not versed in all of the ins and outs of SketchUp, but I used to be able to crop jpegs in my AutoCad for Mac software and do things like wallpaper layouts or add and scale backdrops outside of windows in 3d sets. I then would import my file into SketchUp and the jpegs would import and be visible within in the model. For whatever reason–maybe its the SketchUp 2023 version, when I import my cad files with jpegs, the jpegs are ignored during the import process. Is there a work around for this?

Thanks for the help!

1 Like

As to my knowledge jpgs and such do not transfer with a dwg file. It doesn’t in the PC world but I would assume the same in the AutoCAD for Mac world. We in the PC world get around this but using eTransmit ,it bundles the dwg file and any and all associated files into a zip file. But this is only for opening the dwg in another users AutoCAD system. I don’t think that there is a solution for this.

Edit: Well, I stand corrected. I just tried inserting a jpg floor plan into AutoCAD 2024, saved the file. I was able to open the dwg and see the inserted jpg plan in SU. I thought I had tried this several years ago and it didn’t work. I’d be glad to help test any files for you.

Like this?

Wallpaper Panel 1.dwg (252.2 KB)

So this file has both of these jpegs referenced it it. But when I try to open in sketchup the files get ignored in the import. Would love if you could help trouble shoot this.

These are the two images

——— Post edited due to actual solution found later. I was just confirming a similar result and taking a guess, I guess my guess wasn’t good in the end. go read the actual solution ———

Are the images the same? AutoCAD sees one of them but is looking for “BelN8jcA”

So far the one file IS working from AutoCAD into SU, at least for me on a PC…

1 issue is that the images are not stored inside this DWG , so when you import them into SketchUp they are not brought in.

I’m on windows and if you have the 2 files that are missing in the same folder as the DWG in on your computer - Then SketchUp will load them in

The file itself is actually looking for a folder in the same location called “Reference” if the images are in there, it will also load them in.

Thank you! This was exactly the issue. Im not sure why they paths weren’t linking properly, but I reloaded them and my import was successful.