Im having trouble with misaligning of 2D sketch

STS R mistake.pdf (293.7 KB)

we’re going to need more infos, you know ?

like what are you doing, using what, sketchup only or layout, can you show what it looks like on your screen before export…

we’re not magiciens here :slight_smile:

Neither am I, Im new to this program, how was I suppose to know you needed more info.

Im using sketch up to make the 2D design and then bringing the outline to layout where I add the lines for measurement and markings. I attached a photo with what it looks like before I export it to a pdf.

Thanks for your help

ahhh, so it’s a layout problem :slight_smile:
(I’m changing the tag so it’s in the layout section)

could you share you layout file aswell ?

I’m not a layout wizard, but there are some on this forum, and using your file, they might see something.

(either drag it here in the answer box, or using wetransfer / drive / else)

Does it happen whenever you export ? I mean raster / vector / hybrid mode ? or only in a specific mode ?
(click on your 3d model, and in the “sketchup” panel on your right, change the output to vector or raster or hybrid)

R STS .layout (1.9 MB)

Ohhh ok thanks! Heres the layout file

I just export it through the (apple pdf)

A couple of issues I see. First, the part of your model you are looking at its at a relatively long distance from the origin. This is creating the weird alignment you’re seeing. The other thing is you have not created scenes in your model for the viewports in LayOut. Instead you’re using the Last saved SketchUp view. This means if you go back to the SketchUp model to make any edits, the viewport will get screwed up in LayOut.
Screenshot - 6_3_2024 , 7_15_57 AM

It would be best to keep the model close to the origin. There’s no need to string out bits of the model down the axes as you have done so. Really you should need to make 2D drawings of your 3D models either. You can get the 2D views of the 3D model by setting the camera to Parallel Projection before creating the scenes.


Create a scene for each view you need.

You should be using groups and components for the walls, floor, various electrical boxes, and other elements. With the proper use of tags you can keep the entire model located close to the origin and you won’t need multiple copies of everything.

Again, you don’t need to be making 2D drawings based on your 3D models. Doing so is just more work and makes file management more difficult. This is a screenshot from SketchUp of one of your 3D models.

By the way, your dimensioning is done in feet and inches but you selected a metric paper size. Do you really want this on A3 paper?

1 Like

FWIW, I reworked one of your views. I added the perspective view to show that both 3D annd the 2D elevation show the same geometry. Right click on a viewport and choose Open with SketchUp to see how the model is set up.


And note in the PDF there’s no shifting of the model when the viewport gets rendered during export.
R STS reworked .pdf (2.8 MB)
R STS reworked .layout (2.8 MB)

1 Like

Wow! that looks amazing! yes i’m not the most skilled when it comes to these programs so i’m still learning.

So you made a scene and brought that into the model, how did you change the color to white? did you just do that in the 3d model? Or is there a quicker way?

Thanks!

I did it on A3 paper because I assumed the paper really didn’t matter I just changed the measurement text myself because I didn’t know how to change the measurement type.

The scenes are in the SletchUp model. Each scene has a different camera location suited to show the model as needed. Each scene uses a different style, too. The perspective scene uses the Shaded with Texture face style and the elevation uses the Hidden Line face style.

Sounds like you should take some time to go through the instructional materials at learn.sketchup.com.

Maybe the paper size doesn’t matter for your use but if the thing is going to be printed, paper size is probably important. As for dimensions, set the appropriate units in the Dimension Style panel. Look at the .layout I shared.