I'm getting this error message 'uninitialized constant RubySoft'

Then it lists a whole load of info relating to my file paths

Can anyone help me?

This is caused by one of your extensions, most likely… We need more information, what you are doing and the full error message.
It would be nice if you could fill in your forum profile, then we would also know which version of SketchUp you are using…

OK profile updated.

I recently installed Profile Builder v4 and disabled v3
I updated 4 Trimble Extensions - Sandbox Tools, Revit Importer, Trimble Connect and Trimble Scan Essentials

This is the error message I get each time I start up SketchUp;
—:----
Error: #<NameError: uninitialized constant RubySoft
Did you mean? RUBY_VERSION>
c:/users//appdata/roaming/sketchup/sketchup 2023/sketchup/plugins/rs_window/resources/libraries/stringarrayhash_functions_lib.rbe:1:in <main>' C:/Users/****/AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window/RubyWindow_Start.rb:2:in eval’
C:/Users/
/AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window/RubyWindow_Start.rb:2:in require' C:/Users/****/AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window/RubyWindow_Start.rb:2:in <top (required)>’
C:/Program Files/SketchUp/SketchUp 2023/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2023/Tools/extensions.rb:197:in load’
C:/Users//AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window.rb:18:in register_extension' C:/Users/****/AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window.rb:18:in module:RubyWindow
C:/Users/
/AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window.rb:10:in <top (required)>' Error Loading File C:/Users/****/AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window/RubyWindow_Start.rb Error: #<NameError: uninitialized constant RubyWindow::StringArrayHash_Functions_Lib> C:/Users/****/AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window/RubyWindow_Start.rb:2:in <top (required)>’
C:/Program Files/SketchUp/SketchUp 2023/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2023/Tools/extensions.rb:197:in load’
C:/Users//AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window.rb:18:in register_extension' C:/Users/****/AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window.rb:18:in module:RubyWindow
C:/Users/
/AppData/Roaming/SketchUp/SketchUp 2023/SketchUp/Plugins/RS_Window.rb:10:in `<top (required)>’
–:–

Please let me know if there is anything else I can provide.

The message is indicating that the problematic Extension is RubyWindow, by RubySoft.
You need to contact to them and ask if it is designed for your SketchUp version. It seams the last update happened at 2021… so perhaps it will not necessarily work on newer SketchUp. :frowning:

1 Like