Error message when opening SketchUp

Hi, whenever I first open up SU I get an error message, any ideas what a fox might be? Here’s a c&p of the error messaage:

Error Loading File /Users/marcus/Library/Application Support/SketchUp 2015/SketchUp/Plugins/su_advancedcameratools/advancedcameratools_main.rbs
Failed to read RBS file.
Error Loading File /Users/marcus/Library/Application Support/SketchUp 2015/SketchUp/Plugins/su_dynamiccomponents/ruby/dcobservers.rbs
Failed to read RBS file.
Error Loading File su_sandbox/GeometryHelpers
Could not find included file ‘su_sandbox/GeometryHelpers’
Error Loading File /Users/marcus/Library/Application Support/SketchUp 2015/SketchUp/Plugins/su_sandbox/sandboxmenus.rb
Error: #<NameError: uninitialized constant Sketchup::SandboxTools::DefaultManager>
/Users/marcus/Library/Application Support/SketchUp 2015/SketchUp/Plugins/su_sandbox/sandboxmenus.rb:33:in <module:SandboxTools>' /Users/marcus/Library/Application Support/SketchUp 2015/SketchUp/Plugins/su_sandbox/sandboxmenus.rb:24:in<top (required)>’
/Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in require' /Applications/SketchUp 2015/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:inload’
/Users/marcus/Library/Application Support/SketchUp 2015/SketchUp/Plugins/su_sandbox.rb:45:in register_extension' /Users/marcus/Library/Application Support/SketchUp 2015/SketchUp/Plugins/su_sandbox.rb:45:inmodule:SandboxTools
/Users/marcus/Library/Application Support/SketchUp 2015/SketchUp/Plugins/su_sandbox.rb:29:in `<top (required)>’

@PLCommercial
I suspect one of your ‘other’ extensions [possibly a render plugin] is creating an ‘observer’ that is clashing with ‘su_dynamiccomponents/ruby/dcobservers.rbs’…
do you get the load error if you disable any render extension in ‘Preferences’?
do you get the load error if you disable ‘su_dynamiccomponents’ in ‘Preferences’?

there are others that add observers, what extensions do you have installed?
john

Are you starting SketchUp from the icon or are you double-clicking upon a SKP file to start SketchUp ?

Make sure you download and install the latest Trimble extensions from the Extension Warehouse (that you use.) Looks like errors happen with SandBox Tools, Dynamic Components and Advanced Camera Tools.

These cannot be copied over from old installs, especially SketchUp 2013 and earlier.

Hi, I have installed Sketch Up Pro trial version. However I cannot use sandbox tools. They merely do not show up anywhere and at the start sketchup gives load errors, this is what I have done so far:

1-No I have not installed plugins from any older versions, I have not installed any additional plugins. Just native good old sandbox tools do not show up when I enable them from preferences. And SU begins to show up load errors when sandbox is enabled.

2-I have tried deleting shipped extensions folder and reinstall the newest sandbox rbz file from extension warehouse. It did not work at all.

3-I have uninstalled and reinstalled SU again and again. I have deleted everything about skecthup, even I had to edit and delete any info about SU at regedit. And reinstalled again it did not work.

4-I have started SU from the icon and upon a skp file both. None of them helps.

I have lost hours and I am in a great hurry. Please if someone can help that would be very understanding and caring of him/her.

Thank You.

It would help you copied and pasted the actual error message you’re getting. Just saying you get load errors isn’t enough.

Error Loading File C:/Users/Emre Can Yılmaz/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/su_sandbox/geometryhelpers.rbs
Failed to read RBE/RBS file.
Error Loading File C:/Users/Emre Can Yılmaz/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/su_sandbox/sandboxmenus.rb
Error: #<NameError: uninitialized constant Sketchup::SandboxTools::DefaultManager>
C:/Users/Emre Can Yılmaz/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/su_sandbox/sandboxmenus.rb:33:in <module:SandboxTools>' C:/Users/Emre Can Yılmaz/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/su_sandbox/sandboxmenus.rb:24:in<top (required)>‘
C:/Program Files/SketchUp/SketchUp 2016/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2016/Tools/extensions.rb:197:inload’
C:/Users/Emre Can Yılmaz/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/su_sandbox.rb:45:in register_extension' C:/Users/Emre Can Yılmaz/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/su_sandbox.rb:45:inmodule:SandboxTools
C:/Users/Emre Can Yılmaz/AppData/Roaming/SketchUp/SketchUp 2016/SketchUp/Plugins/su_sandbox.rb:29:in `<top (required)>’

You should not have done this. SketchUp keeps a master copy of these extensions in its distribution’s shipped extensions folder and restores them to your plugins folder automatically. The ones in the distribution are assured to be compatible with the installed SketchUp.

Two possibilities come to mind:

  • Did you install as administrator? If not, there could be read permission issues on files
  • You may have gotten an error during the download that damaged the geometryhelpers.rbs file. Try starting over with a new download.

I have done that aswell, installed as admin, opened as admin. I does not help.

unbelievable! now I have installed SU Make and sandbox works…But I am terribly concerned since I was going purchase SU Pro, what if it does not run sandbox?

sandbox does not differ between Make and Pro. So, clearly you did something different this time. I don’t know what, but maybe as simple as getting a clean download.

Just to eliminate a possible download error I have downloaded Pro version twice, but the difference may be that SU Make installation file is older I have bumped into it in my download folder. It is SU 2015. Pro version with sandbox problem is 2016…What do you think? It seems when I purchase pro I will still have the same problem?

Thank you by the way for sparing time and all of you who has answered…I have really lost a very precious time because of that. For now I have no choice but to move on with Make, and I will use Pro for dwg import export…

What would you recommend me about the problem? Shall I buy Pro and then try asking for help from the support team? Because the only change from now would be just entering serial that I will purchase, then I will be using a problematic SU Pro which I am already using in trial mode…

As already answered, there is no difference whatsoever between how SU Make and SU Pro handle the sandbox tools. Something you are doing during install is causing the issue, not Make vs Pro.

Problem is completely solved brother,

1-as you say it is not something about pro and make but it is something about 2015 and 2016. Sandbox worked with make because the installation file was older and it was 2015 make.

2-i have found the reason of the problem at a russian site thanks to translators i could understand that it is something about non english alphabet. it is very normal why people using english do not bump into such a problem. anyways the problem is my user name at computer which has a turkish letter “ı” that cannot be found in english alphabet. for su2015 this is not a problem. but su2016 cannot read the files because of the folder name with a non-english letter. but because i am using win 10, it is very problematic to change the user folder name. after losing almost two days, finally i have my sandbox tools at 2016 pro

3-i hope that su team reads this problem and do somthing about it. this is simply a bug.

thank you everyone

I added the bug tag to the topic, which should help to catch the Trimble team’s attention. There were numerous problems with non-English characters in paths when SU went to Unicode, but supposedly they have been fixed. Your case must have somehow slipped through, maybe due to Windows 10, which wasn’t out yet when they did the last round of Unicode fixups.

Well, I’m having the same problem, without any non-English characters…

Fresh SketchUp Make installation on a fresh Macbook pro.

Error at startup since first start:
Error Loading File /Users/phy/Library/Application Support/SketchUp 2016/SketchUp/Plugins/su_sandbox/sandboxmenus.rb Error: #<Errno::ENOENT: No such file or directory - > /users/phy/library/application support/sketchup 2016/sketchup/plugins/su_sandbox/geometryhelpers.rbs:107:ininitialize’
/users/phy/library/application support/sketchup 2016/sketchup/plugins/su_sandbox/geometryhelpers.rbs:107:in open' /users/phy/library/application support/sketchup 2016/sketchup/plugins/su_sandbox/geometryhelpers.rbs:107:inReadValues’
/users/phy/library/application support/sketchup 2016/sketchup/plugins/su_sandbox/geometryhelpers.rbs:45:in initialize' /Users/phy/Library/Application Support/SketchUp 2016/SketchUp/Plugins/su_sandbox/sandboxmenus.rb:33:innew’
/Users/phy/Library/Application Support/SketchUp 2016/SketchUp/Plugins/su_sandbox/sandboxmenus.rb:33:in <module:SandboxTools>' /Users/phy/Library/Application Support/SketchUp 2016/SketchUp/Plugins/su_sandbox/sandboxmenus.rb:24:in<top (required)>’
/Applications/Media/SketchUp 2016/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:in require' /Applications/Media/SketchUp 2016/SketchUp.app/Contents/Resources/Content/Tools/extensions.rb:197:inload’
/Users/phy/Library/Application Support/SketchUp 2016/SketchUp/Plugins/su_sandbox.rb:45:in register_extension' /Users/phy/Library/Application Support/SketchUp 2016/SketchUp/Plugins/su_sandbox.rb:45:inmodule:SandboxTools
/Users/phy/Library/Application Support/SketchUp 2016/SketchUp/Plugins/su_sandbox.rb:29:in <top (required)>'

Tried to remove and reinstall from Extension Warehouse, no difference, cannot use sandbox… very strange! Is possible to solve it?

I noticed this path a couple of places in your error listing. That is not a standard place for SketchUp to install. Did you move it there manually? If so, I wonder if you found a hole in SketchUp’s setup. SketchUp automatically copies the sandbox (and other su_… ) files into your plugins folder as it starts up. It will even restore them if you delete them. I wonder if due to the moved .app it can’t find them (or can’t find all of them)?

1 Like