Errors on starting sketchup 2017


#1

When I start SU 2017 I get these errors and have no idea what to do about them:
Error: #<NameError: uninitialized constant Traductor::Plugin::T6>
c:/users/rathk_000/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:923:in libfredo6_version_valid?' c:/users/rathk_000/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_!libfredo6/lib6core.rbe:971:ineffective_load’
c:/users/rathk_000/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/fredo6_roundcorner/__loader__roundcorner.rbe:1:in <main>' C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:ineval’
C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2017/Tools/extensions.rb:197:inload’
C:/Users/Rathk_000/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_RoundCorner.rb:57:in register_extension' C:/Users/Rathk_000/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_RoundCorner.rb:57:inmodule:Fredo6
C:/Users/Rathk_000/AppData/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins/Fredo6_RoundCorner.rb:26:in `<top (required)>’
Error Loading File ZLoader__RoundCorner.rb
Error:


#2

They’re load errors related to some of Fredo’s extensions. Download and install the latest LibFredo6 to make sure everything is up to date.


#3

Thanks, I’ll try that. M


#4

I’ve found that any time I install a new Fredo6 extension or update existing ones, it’s best to also install the latest LibFredo6 at the same time. He frequently updates his extensions and LibFredo6 is no exception.

You can use his tool for checking the revisions you have installed to see that they are up to date. Here you can see I have a few that need to be updated on this computer.


#5

Thanks, seems I can’t install any extensions I think 2017 is not working any more. I give up :frowning:


#6

What do you mean you can’t install any extensions? Don’t give up. Be specific about what happens when you try to install extensions. Exactly how are you trying to install them?


#7

Thanks.
I first installed LibFredo6 and nothing happened, no dialogue, nothing. So I tried installing FredoCorner and got an error image
None of the other extensions I have installed seem to work.
I have been low level using SU since it was launched and the last version that worked properly for me was 2016. The new on-line version is no use to me as my connecting is very slow.


#8

HOW did you install these? Exactly.

These extensions will work with SU2017 if they are installed correctly. Perhaps it would be a good idea to start over installing them from scratch to make sure there are no errors.

When did you install SketchUp 2017?


#9

Having downloaded them to my downloads folder,
I have gone to windows\extension manager selected install extension, seledted them for install andnothing. I have tried that several times.
Thanks


#10

Where did you download the files from?

Let’s start over. Follow these steps in this order.

  1. Close SketchUp.
  2. Open Windows File Explorer.
  3. Go to User/App Data/Roaming/SketchUp/SketchUp 2017/SketchUp/Plugins. (App Data is normally a hidden folder. If you need help making hidden folders visible, see this.)
    4.Find the following folders: Fredo6_!LibFredo6 and Fredo6_RoundCorner. Also find Fredo6_!LibFredo6.rb and Fredo6_RoundCorner.rb. Delete these folders and files.

Next, make sure SketchUp is installed correctly.
5. Find the installer file you downloaded for SketchUp 2017.
6. Right click on it and choose Run as administrator.
7. When presented with the option, choose Repair. Let the repair installation complete.
8. Check to see that you have the latest versions of LibFredo6 and RoundCorner. Look on Sketchucation to make sure of this.
9. Open SketchUp and install LibFredo6 first, then RoundCorner.


#11

Yippeee!
Thank you, all seem to be working now and ran the Check for updates and all fine.
Thanks again. I will keep a copy of your advice on my desktop for future reference.
Regards
Mike