I seem to be unable to upload any new models

For the past little while, I’ve been attempting to upload a single model, but each attempt just gives me the same “There was a problem uploading…”.
The model is large at 12 MB, but doesn’t break the bank’s limits, the text is not explicit and I’m attempting to upload a single model, not batch uploads.
Are you folks encountering any issues that we need to know about?

End of Support Policy | SketchUp Help

SketchUp Make 2017 Access | SketchUp Help

So, am I to understand that I can’t even UPLOAD the models so that they might be downloaded by newer versions? I understood that only newer versions could be downloaded, but now, I have to change to a new version just to upload as well?

Are you talking about upload to 3D Warehouse?
Perhaps you can still upload via your internet browser
3D Warehouse (sketchup.com)
image (It is in a Right upper corner)

Or you can also use the web app… : https://app.sketchup.com/

I have only used my browser to upload my models using that upload link you pictured. I’ve been using the same procedure since I first started creating models. Yet, for some reason today, I select the model, add the title, the body text, the 5 tags and the category, but I keep getting the same notice over and over: :“Something went wrong while uploading your model, please try again.”

I just tested with a 2017 version of file and uploaded successfully. Even I can download as a 2017 model!


Only the author can download as a 2017 model, visitors can only download in 2020 and newer format.

I’m going to upload an old sci-fi tile to see if the problem is the actual file/name/description content.

I just attempted to upload a simple tile model using a simple descriptive comment, three tags and a 1.8 MB file…same result, unable to upload.

BTW…I did a complete restart on my system, and just prior to attempting the upload, my system was using approx. 3% CPU and 14% Memory.

You can share your model here (Drop into your reply post) , and I can check how upload goes for me…

I just tried again, but this time, the upload was successful. I don’t get it.

I’m posting the link here, just in case you can come up with a reason for the hair-pulling excitement, especially since I’m getting a little short of that particular resource. Thanks for the response.


Probably a temporary server issue in your area. Since this is a hobby for you, don’t let it get to you. Put it aside and go do something else for a while.


Modeling IS what I do when I have more than a few minutes of free time. I use it to decompress, or relax. But…thanks for the advice.


I feel the same way about this. (Check my profile).
In such annoying cases like this, I always think: how much more pleasure (fun) does my hobby (Sketchup) bring, than annoyance… :innocent: :beer:

1 Like