I pressed something wrong on the keyboard and everything disappeared

I was trying to deselect everything by keyboard commands, and then it asked if I want to save the file, I said yes, and everything disappeared including the SketchUp window.
I had to reopen the program because it wasn’t reacting to clicking. When I opened the file, I found only the last hidden component. I’m so confused. I’m not sure if it was a reaction to a wrong command or a crash.
I also tried to ‘revert’, but nothing happened :frowning:

What do you mean by “deselect everything”? Were you trying to hide everything?

Were you using components in your model? If you look at the In Model components are they still there? If so, you can select them and drag them back out into the model space. Unfortunately if you deleted loose geometry or groups that stuff will be gone.

What does Outliner look like? Are there elements of your model shown there?

there is a command ‘select none’ in window > edit. but I wanted to learn to make it by a keyboard. for some reason didn’t work and I stupidly started experimenting with combinations. I think the last one was command+A+W.

oh, I found them. there are so many from the warehouse, so I haven’t noticed them in panic. Thank you so much! I still wish I knew what exactly happened.

Maybe you hit the Delete key by mistake. I’ve seen others report that sort of thing.

By default Ctrl+T is the keyboard shortcut for Select None. Maybe it is safer to use that than to set your own.

I was trying to repeat the one that already exists. Thanks for the advice anyway :blush:
Screenshot 2020-05-28 at 18.55.20

Oops. I didn’t catch the Mac thing.

Why were you trying to recreate it since it already exists?

I tried not to recreate it but use it. maybe I just pushed the wrong buttons.

⌘ A W
That will select all, then close the window, assuming you held the command key down.
⌘W should close the window in any program that has a window, but if you haven’t saved it should warn you and prompt you to save the file.

1 Like