I can't see a model. Only see green screen. Tools appear to work .. but cant see shapes. This is a new model

#1

#2

on another note the mouse can draw ???

#3
  1. Uncheck “Use Fast Feedback.” - In the SketchUp menu:
    Windows OS: Go to Windows tab > Preferences > ”OpenGL” and uncheck “Use Fast Feedback.”
    Mac OS: Go to “SketchUp” tab > Preferences > ”OpenGL” and uncheck “Use Fast Feedback”
    If this doesn’t make a difference, I would suggest turning back on and continuing down the list of possible fixes.

  2. More than one monitor
    Assuming your computer is up to the minimal system requirements, sometimes the issue is using your computer with more than one monitor. How can that be so? Oftentimes, computers will have two video cards; an “onboard” card and a nice, powerful GPU. People will plug one monitor to the GPU and one to the less powerful “onboard” card and while that might work for daily use, SketchUp doesn’t like that. It needs to pump all of the output from the powerful GPU. If this is the case, you will need to make sure the secondary display is plugged directly into the GPU and not into a dock or plugged into a less powerful, on-board video card.

  3. Cranky Extensions
    If you use extensions and one of them is outdated or incompatible with your version of SketchUp it will throw a fit and bring SketchUp crashing down. In this case you would want to test that by disabling your extensions and bringing them back up one at a time. Here’s how to do that: https://help.sketchup.com/en/article/3000264#enable-extension

  4. Outdated video card drivers (mostly impacts Windows PCs), you’ll want to make sure you’re running the latest & greatest video card drivers. I usually visit the website of my video card manufacturer to make sure i’m getting the best drivers. It should be noted that SketchUp Pro 2017 and newer does require a 3D accelerated video card (or Graphic Processing Unit) with its own dedicated memory. Some common GPUs are AMD’s Radeon and Nvidia’s GeForce. If your computer only has an Intel video card, then your system may not be up to the minimum system requirements.

#4

Go to Window>Preferences>OpenGL. Untick Use Fast Feedback. Does that fix it?

Based on your profile, your computer’s graphics card is notorious for poor OpenGL support.

#5

Yes— un tick fast feedback.

This is a work laptop. They finally purchased license for me. The graphics look horrible compared to my Mac. Could you recommend some options for graphics card.

#6

Generally Nvidia GeForce and GTX cards seem to be the best at correctly and robustly supporting OpenGL. If it’s an option to upgrade to a notebook computer with something i the GTX10xx or even GTX20xx range, that would be good. From the huge number of threads reporting issues here, I wouldn’t even bother putting SketchUp on a computer with integrated graphics.