I cannot open my file “this does not appear to be a sketchup model”

I’ve been working with a project model for months. Sometimes i work on my laptop and sometimes i work on my desktop. Im using my WD hard-disk. The file size is 203mb so i cant upload on here.

it could have been a problem during transfer from one to another. the bigger the file, the higher the risk of corruption (any file, not just SU)

203mb it too much for the forum, but you can use services like wetransfer to upload it and generate a link.

At least 203mb it shouldn’t be full of zeroes, maybe @colin can extract something / fix the corruption, but don’t take my word on it :wink:

If you can upload both the SKP and the SKB at once, it might help him.

also, have you tried opening your skb (backup file) ? Rename the .skb into .skp to open in in SU. granted, you’ll loose the last save, but not all of your work (and if it opens, it might tell us that the corruption happened at the last save)

Yes ive tried opening .skb file but its a bit early version of my latest work so there is a much difference with final version. so my all hopes are with colin right now lol. Please help me this is my school finishing project. here is the link of my file: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free