I cannot open my file "this does not appear to be a sketchup model"

If there was any activity on the disk before the recovery attempt it is likely that the system’s record of where the file was stored has been overwritten. Recovery is then usually impossible. Sorry!

Hello Mr @colin, can you help me? please… i have the same problem sketchup.
[Review Mezanine.skp - Google Drive](https://I cannot open my file “this doees not appear to be a sketchup model”)

Your file is full of zeros. Look in the same folder to see if there is an SKB copy of the same model. If there is, rename the .skb to be .skp, and see if it opens ok.

I’ve done it by changing the skb format to skp, but it still can’t open with the same message, namely “this does not appear to be sketchup model”. Is there any other way so i can reopen this sketchup file? Please help me mr @colin

If the SKB file has the same problem the SKP had, then no, nothing would recover it. You could put the SKB file online for me to try as well.

Continuing the discussion from I cannot open my file "this does not appear to be a sketchup model":

Hi Sir. Can you help me with my file too. same problem here.

Thank you.

I don’t know what sort of file that is, but it isn’t a SketchUp file. Can you look to see if there is an SKB copy of the same model, in the same folder as the SKP?

Hello @colin , I have same problem that my skb file is unable to open even I changed it to skp. Could you please check it out? I have serious problem with loosing my entire data and only skb file left on hand…

The link;

There is a lot of blank data inserted at the start of the file. Even with that removed the file is missing some important parts. I couldn’t recover anything useful.

I’m really sorry to hear that, is there any way to bring it back or it’s absolute gone? because, I will lost 3 weeks of work…

If Colin can’t recover anything, most likely no one else can…
Start over and make backups…

@colin , I just found skp and temp files of same model from data recover. Are they could be used for recover the drawing?

Both of those files have the same problem, where a lot of extra data has been inserted in front of the model data.

Hi Mr Colin, I have a file also facing the same issue…please kindly help me out for my model…I have same problem that my skb file is unable to open even I changed it to skp. https://drive.google.com/drive/folders/1NE0yYahSTbOsbdGv7VxcjwuOVoJuKtEB?usp=share_link

Hi @colin I have seen you help a lot of people with this issue, I was wondering if you could take a look at my file? It is a semi-long story though and I am sure my issue is different than the issue above. I am an architecture student, and was using a trial version of Sketchup and working on this model a few weeks ago. I worked on it for a couple of days on March 4th and 5th. Today, I went to look for the file which I believed to had been saved in a folder on my desktop and it was not there. Multiple documents I had pulled as 2D drawings were there in the folder where the model had previously been (to my belief). I checked around the Sketchup files to find any auto-saved or recovery versions, but found nothing. The trial version does still say auto-save is on. It was not in the recent files for Sketchup either, nor the trash bin on my computer or literally anywhere on my hard drive. It is like it disappeared. If you have any suggestions for a place I could look, or a way I could locate it. I know the file name and date… That being said, I did what I could only think to do and used a third party recovery program to scan my drive. It was able to locate the file and “relocate/download” it to my drive. I am attaching the file here. Sketchup gives me the message “this does not appear to be a sketchup model” message when I try to open it. I assume because of the recovery process, or whatever originally made it disappear perhaps. I am hopeful maybe there is a way to “uncorrupt” or maybe “unlock?” the file. I am open to any and all suggestions. I have tried a few mentions on some threads here. Without this file I will be pretty behind for my classes
THIS IS CURRENT MODEL.skp (988.9 KB)
:frowning:

For the question of finding files everywhere quickly, you could try this utility:

https://voidtools.com

It will instantly show you all .skp files on all of your drives. Maybe that will show the missing file.

For the one you attached, it seems to be some random data, that is mostly empty. It isn’t a SketchUp file.

1 Like

There are many tools and methods to search a disk for a named file. If yours wasn’t erased, just misplaced, that should find it. But if it was erased, my experience is that file recovery tools don’t work reliably on binary files such as skp.

1 Like

Hello @colin

I currently have the same problem on this file :

I worked on it for weeks now and it really compromise my mission toward my client, I would be so grateful if you could have a look on it !

That file is 28 MB of zeros. Look in the same folder to see if there is an .skb copy of the model.

Thank you, @colin , here it is :

How come a full functional skp file turns into only zeros ?..