My Sketchup file won't open. Error message appears: "This model does not appear to be from Sketchup."

To free up space on my local disk, I deleted some folders. But many things are gone, including desktop icons and my sketchup files.

I restored the folders that I had deleted using the MiniTool Power Data Recovery 6.5 program.

The files came back but now they are not opening. This message appears every time: “This model does not seem to be from sketchup”.

I already tried to open the backup file but without success. I tried to rename but to no avail.

I need help.

It’s not unusual for files to be scrambled or otherwise corrupted with this sort of thing. I compressed your file with 7 zip which reduced it to about one tenth of the size of the .skp file. If the file was a viable SketchUp model it should have zipped up to about 95% of the size of the .skp. I wouldn’t hold out much hope for it, unfortunately.

@DaveR Were you able to open my file? I’m using Google Translater and I didn’t quite understand your answer.

No. I could not open it. The file is badly corrupted. @colin will probably take a look at it but I’m guessing it’s too far gone to recover. You might want to go ahead and get started on redoing it.

Okay, very grateful for the help.

I’ll wait for the @colin to see if there’s any way to get it back.

No hablo portugués pero tal vez entiendas un poco español.

Cuando haces lo que hiciste es muy probable que los archivos sean corrompidos, mejor puedes guardarlos en tu cuenta de Trimble connect, y después volver a descargarlos a tu computadora.

The file is 744 MB of zeros. If you zip compress the file you’ll see that it ends up as about 700 kb. There is nothing in the file.