I cannot import IFC files (SketchUp Pro 2022, Mac M1 Max)

Hi!
I cannot import any IFC files (IFC2x3) to SketchUp Pro 22.0.353. It does not exist as file option in the drop down menu inside the import window and the IFC files are shaded grey. I updated SketchUp from an older version but the newest version did not solve the problem. A colleague to me has same version on the macOS and SketchUp, but not the M1 chip. He can easily import IFC files by drag-and-drop and through the import window. I use the standard Architectural millimeters template.
Any ideas what to do?

Update: I have been able to “solve” the issue temporary by installing SketchUp Pro 2022 in Parallels (Windows 11). I don’t see this as a convenient way to use IFC files in the Mac version but it at least works.

The problem is that the IFC importer hasn’t been updated for ARM64. A better performing work around for now would be to set SketchUp to Open in Rosetta, in Get Info. Then the IFC importer will work.

What I did was to duplicate SketchUp.app in my Applications/SketchUp 2022 folder, and set the copy to Open in Rosetta. That way I get better performance when I don’t need extensions that have not been updated, and if I need those extensions I run the Open in Rosetta copy. Pretty sure it will perform better than via Parallels.

Thank you for the solution! Any idea when the IFC importer will be updated?

I do know that it is being worked on. I don’t know went it will be in an update. I will suggest to my colleagues that the extension files could be posted before the next full release of SketchUp.