Anyone having problems while importing ifc files on mac? Latest SketchUp version

I can’t even import the ifc files I export.
if I import them in windows I have no problem.
I have the latest version of sketchup (23.0.418) and a macbook pro with M1 processor.
attached is an example of a file I can’t import. (724.4 KB)

Does it fail immediately for you, or get stuck?

I’m trying the file, and it is taking a good amount of time. I will leave it trying, and check back later.

It never finishes loading on mac. I tried the same file on windows and it loads. Only takes 1 minute.
I have tried with other ifc files and the same thing happens and on Mac

I didn’t time it, but after a while of being stuck at about 25%, it was then imported.

I did try the file with 2021 and 2022, and for both of those it immediately failed with an error message.

I waited 20 minutes and had to restart SketchUp. I tried almost 3 times and any of them was imported. On Sketchup for windows it last only one minute to be imported.
The ifc file was exported with SketchUp and I can open without problem in other viewers like BimCollab zoom.
Anyone having those problems?

Here is what I got. I turned off Profiles.

Thanks @colin, I tried again and it finally was imported but this time it take 9 minutes. There should be a problem with ifc files in the last SU version. It’s no normal that a small ifc file takes so many time (and not on windows which is running under parallels on my mac).
I’m trying to convince the Spaniards that they can work with SketchUp as they do with Revit but ifc is a must in order to collaborate with other colleages.
At the moment I’m able to share files to use Spanish BIM5D software which requires ifc files and share models with mechanical and structure engineers (both of the uses CYPE software) and they need ifc files too.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.