I am signed in but sketchup won't let me in

I just got signed out of my account and had to resign into my sketchup account and see that it is active but when I go to my desktop to open sketchup it prompts me to sign in again and doesn’t allow me open it on my computer.

Try signing out intentionally once, then sign back in.

I have already tried that

You logged out through the SketchUp app?

I tried redownloading sketchup but it still won’t let me sign in.

That’s not the same as logging out in the app.

I can’t sign in through the app. I tried clicking on the sign in but nothing happens.

Use the top menu bar Help menu. The bottom item is sign out. Then go to the same place and sign back in.

I can’t sign in. when I click on the sign in button it then says launch browser again and I can’t sign in. Can I speak to management to help me resolve this issue?

You are not talking to SketchUp employees, this is a user Forum. I don’t work for Trimble. You can contact support here:Contact Support | SketchUp Help.

However, at the risk of repeating myself:

Have you followed these instructions? Ignore the green sign in button. Use the Help menu, sign out, then sign back in from the help menu within SketchUp

1 Like

Oh got it whoops,sorry

endlessfix is right in that the forum is not an official support page. But, some of us are checking for posts where it really needs someone at SketchUp to help.

I did see your question, and will reply again if the other suggestions don’t work.