HP Spectre and SketchUp - Is it working for you?

I’ve seen a small handful of reports of SketchUp crashing unexpectedly within a minute or two of launching. The way it crashes and the fact that it is on an HP Spectre are an interesting coincidence. Is anyone here using a Spectre? How does SketchUp work for you? I am attempting to make contact with an HP agent to help with testing to see if we can get to the root of the issue.

No Spectre. But I do notice that it is a family of (Win10 Home) laptops all with iCore (i5|i7) CPUs.
They all have SSDs (256GB|512GB|1TB) but a range of Intel integrated (Iris Pro|UHD620) or dedicated Nvidia (MX150|MX250|GTX1650) graphics.

Can you narrow down the machines to certain hardware options ?

Still collecting data. The general model can be found here: https://support.hp.com/us-en/drivers/selfservice/hp-spectre-15-df0000-x360-convertible-pc/23238160

I’ll get back to you after our next remote access session.

We have received a few reports of SketchUp, as well as some Adobe products, crashing on HP Spectre machines. It seems there are some settings that cause graphics/power management conflicts. Here are the suggested steps to fix this configuration issue.

  1. Turn off the “Connected Standby” feature. This requires a registry edit and while this is usually safe I would recommend backing up your registry before making any changes. Instructions for turning off “Connected Standby” can be found here under Item 2 - Step 1: https://surfacetip.com/ultimate-tips-max-surface-pro-4-battery-life/#2

  2. Adjust the Nvidia settings for Power Management using these steps:

    • Open up your Nvidia control panel. This can usually be done by right-clicking on a blank area on your desktop and selecting Nvidia Control Panel.
    • On the left hand side of the Nvidia Control Panel click on “Manage 3D settings”
    • On the right hand side, click on the tab “Global Settings”
    • Scroll down on that list until you see an option that says “Power management mode” and change this to “Prefer Maximum Performance”
    • Click on Apply, then reopen SketchUp and that should do it!

I was recently on a Surface Pro 7 for the past week and the battery was not as published and I decided to return it and buy the spectre 13, the new one with the i10. While I was testing the Surface Pro I did not experience these persistent crashes while working on sketchup on the surface pro which is similarly equipped.

Now on the Spectre, like clockwork it happens a minute or 2 into the project. I have disabled the Connected Standby and restarted the laptop, but I am still experiencing the same.

I don’t recall this happening before the 1909 update but I don’t remember actually doing much work on this laptop when the 1909 became available.

*Update
uninstalled 1909 update and restarted, still experiencing the same crash. Here is the Crash Report # 195647

*Update 12/7/2019 4:46PM
So I have returned all updates to the laptop. Enabled Fast Feedback in Open GL setting in sketchup and it seems to be working without the crash. I have also increased it to 8x.

*Update 5:22PM
I was able to use my document for at least a good 35 minutes before crashing… It seems to me that there is an issue with graphics support/OpenGL and Intel drivers. It lies there…

1 Like