How to use Cloud v8?

Hello all,

I have an XYZ.TXT file I would like to import into Sketchup Pro 2022. It is of a survey of a garden we are designing. I have the extension Cloud v8 installed but for the life of me I cannot get it to work how I need it to. I have read through the instructions but im still not getting what I need.

Can someone guide me in the right direction please.

XYX.TXT file attached for reference.


This is the way I would deal with it.

Rename the file to .csv.
Open in a spreadsheet editor and delete the first column.
With the x- and y- values being so large the points will be a long way from the origin which could create problems so I found the minimum of the coordinates and subtracted them from the ones in the list.
Screenshot - 12_15_2022 , 8_04_53 AM

Screenshot - 12_15_2022 , 8_05_21 AM
This won’t change the shape. It just keeps the points in a manageable area.

I copied the numbers to another sheet in the spreadsheet and deleted the first sheet. Then I saved the file as a .csv file again.

In SketchUp I selected File>Cloud>Import.
Selected the .csv file.
No changes required in the settings.
And I ended up with this. I did not opt to triangulate the points.

Instead I used TopoShaper to do that and create the skirt.


That is awesome Dave, thank you very much.

I am a little stuck though.

How are you getting the csv to put the info in different columns?
What numbers are you deducting etc?

Sorry, im sure I am looking too hard at this!

You’re welcome.

I just opened it with the spreadsheet app. I’m using LibreOffice Calc but Excel should do the same thing. Double clicking on the file after renaming it shows this:

Calc will open the .txt file directly so renaming it was an added step for me. Sometimes that’s needed though.

I deleted the first column leaving just the coordinates.

As I showed, I found the minimum value in each column using =MIN(A3:A176). Then by subtracting that minimum from the values in the column, the minimum values became (0,0,0) and all other coordinates are relative to that point.

I am halfway there,

Would you be able to attach the csv file so I can double check please?

Here you go. The forum won’t take a .csv file so I zipped it up. (2.5 KB)

Thank you, I have got this to work now and I completely understand your workings now. This will save a lot of time!

1 Like