How to set default layer

layer

#1

Help!
I can’t seem to change the default layer in the 2019 version of SU, but somehow I did change it by accident and I can’t change it back. I can’t work on the model until this is fixed and am even afraid to save it this way.


#2

the Pencil icon on the extreme right…

john


#3

Layer 0 should ALWAYS be the “Deafult” layer. You should always leave Layer 0 as the active layer.


#4

How to move it though??? I am dragging it up but it’s highlighting everything and it is tedious with 100s of layers.


#5

You don’t drag or move a layer. Layer order, as far as the model is concerned is not important. If you want a layer to appear higher in the list, change its name to something closer to the beginning of the alphabet.

What exactly are you trying to do?


#6

Yes, I know. I don’t know how I changed it and I can’t seem to easily get it back to layer zero by dfefault


#7

click to Layer 0, it’s one at a time…

john


#8

Just click in the last column.on the Layer 0 line


#9

That doesn’t work. Either mouse button…


#10

layer%20switch


#11

Ah, now I get it. Was it changed? I don’t remember having this difficulty in SU 2018. Click on the other layer thenclick on layer 0 for changing the default. Got it.


#12

It was a check box before and in a different column. Changing the active layer was exactly the same action, though.And you should still be following the long standing rule of leaving Layer 0 as active.


#13

I didn’t change it on purpose. I was just trying to activate a layer and somehow the default got changed to that layer. I like it better the old way with the checkbox where you could see what you were doing.


#14

There shouldn’t be a need to “activate” a layer, though.


#15

Well, to turn it on then…
My model has hundreds of layers, most of which are turned off wile working on it, both for access and for speed.


#16

To make a layer visible then, you just click on the eye symbol on the left side of the Layer name.


#17

My, this is a confusing thread. I am not sure whether the OP is referring to Sketchup or Layout (his profile doesn’t disclose what version he is using). Is there also confusion about the meaning of “turning on”? Are we talking about visibility or currency?

Maybe this will help him:

In Sketchup

Always draw in Layer 0 and keep all raw geometry on that layer. Only use other layers for groups and components.

Layer 0 will always be at the top of the layer list even though the rest are alphabetical. Normally, the pencil icon will show next to Layer 0 and never elsewhere.

In Layout

The built-in templates come loaded with a Default layer and an On Every Page layer. These can be deleted or added to. There is no equivalent to Layer 0.

Layers are not in alphabetical order by default and their order determines hierarchy (so something on a higher layer will show in front of something on a lower one).


#18

It was in Sketchup, not Layout.
The problem,for me anyways, is that the checkbox in the layout dialog box is gone now and it wasn’t intuitive how to set the layer default. I don’t normally change it from Layer0 so when I did it accidentally, I had no idea how to change it back. Realizing that changing the default could lead to all sorts of problems later I was basically halted in my work until I figured this out, with the help of the sages here :slight_smile:

All is good now, and work is progressing again.


#19

You can’t change the default layer. In a way the “default layer” isn’t really a layer, but rather represents the lack of a layer. It cannot be renamed, it is always shown at the top of the layer list and when using Color by Layer entities with Layer0 assigned to them are shown with the color of the the first parent’s layer.


#20

You can sort by color now, on a Mac, thus giving you another possibility to arrange your layers.