Error message "Sketchup - you can not hide the current layer"

I have components assigned to layers. When I uncheck the visibility button, I get the message “you can not hide the current layer”. That’s the whole idea. I can’t figure out how to turn off the visibility. Anybody know what I’m doing wrong?

You need to keep Layer0 set as the active layer and have your components on other layers, then use the visibility box for them.
You cannot hide the layer that has the dot on the left.
And that dot should always be on layer0.

Yes change the CURRENT LAYER to Layer0. It is the primitives layer and should usually be the current layer 95% of your working time. There is also not much good reason to need to hide this layer.

The component and group instance objects are assigned to other layers (whilst their primitive entities should still be on Layer0.) When the objects are hidden or on a layer that is turned off, all their “child” entities will also be hidden.

You name these visibility layers depending upon what helps you organize your work.

my estimate: 99.84% (approximately ;-))

Set the Default Layer 0 as the active layer and leave it that way.
Does SketchUp Support Layers? — SketchUp Help

I refute that for a minority of situations, in the following thread:

1 Like

Just make a new layer and in layers u will c 2 layers. Hide the older layer and c 1st. u will notice then which layer ur working. If not yet solved then plz send ur file i will make clear ur question

Robert here: I had the same problem but clicking the 0 Layer button to make it the active layer doesn’t change anything. When I try to hide the LO_Basement layer, the warning came back. Looking around I noticed in the Entity window that I had the Basement set to Layer 0, instead of LO_Basement. Silly me. When I unchecked the box beside LO_Basement to hide it (the basement), Sketchup saw that entity as being on Layer 0 and said “No”.
I think that comes from drawing the basement as a lot of groups on layer 0, and grouping them all into the OB_Basement entity first, then going back multiple times to edit that layer and mistakenly putting everything into the wrong group when closing out of it.

What version of SketchUp are you using? Please complete your profile.

Is it possible for you to share your model with us? What you wrote doesn’t make much sense to me. Also, relevant to @DaveR’s question, the layout of the layers panel was changed in SketchUp 2019 vs previous versions, and that might cause some confusion.

Too true. Actually, when viewing the 2019 Layers window, one layer only has the pencil tool icon in the rightmost column. How do you change that or what does it indicate, the Active Layer?
Robert

Click on in the column with the pencil for the layer you wish to be active. Correct layer usage involves leaving Layer 0 active at all times. That is, the pencil icon is at Layer 0.

ALL geometry should be created on and left on Layer 0. Only components and groups get other layers assigned to them. With proper usage of layers, there’s no need to chase the active layer because the active layer is always the same: Layer 0.

Perfect. I suspected exactly that, just didn’t know the magic incantation. Thanks to your quick advice, I can get back to work. Many thanks.
Robert

You’re quite welcome. Happy to help.

Before you go much further, you might take a little time to ensure that all edges and faces are on Layer 0. If they aren’t, you should fix that before going on.

Not to worry, it was the new interface that confused me.
I’m up to Oculus Rift for reviewing models, latest quest is too build a deck in VR. The same tool set exists there. It took me half an hour to explore the tape measure, but once you begin to discover some of it’s ‘heads-up’ guides, you have to be a mathematician to apply it effectively. Selecting something from inside itself is another world, you don’t have any idea what you’re about to hide, it might be what you’re standing on. I’m glad we didn’t have this stuff when we were teenagers, experimenting with (soft) drugs at the same time. Might have never come out of there.

1 Like