Hiding/unhiding components


#1

I hid 2 components, and now when I unhide them, they come out crosshatched and will not return to normal. I can not work with them. What have I done wrong?


#2

right click on the cross hatching >> Select Unhide


#3

Great, that worked.
I tried from edit menu, unhide, unhide all, but did not work.
Thanks

CM


#4

That’s fixed.

But the general rule is - don’t “hide” Groups/Components [except perhaps for a few seconds !] as it leads to a headache…
It’s much easier to assign Layers to selected Groups/Instances and then switch ‘off’ the Layers you don’t want.
Also if you are doing this ‘hiding’ to help when working within a ‘container’ context, use View > Component Edit > Hide Rest of Model [toggle]… etc, to temporarily give you a clear view…


#5

I would guess that what you originally hid were the objects that were inside the components. To unhide them you would have to enter the context of the component (edit the component) and perform the Unhide All from there. Unhiding All from the model level doesn’t affect objects that are inside groups or components.

Post the model if you want answers that aren’t mere guesses.

Anssi


#6

Regarding layers.
I created a layer, one of several. When I uncheck the visible box, I get an Error message that says I can not hide the current layer. Is there an obvious thing I have done wrong?


#7

The Default Layer 0 must always be the Active Layer.

Does SketchUp Support Layers? — SketchUp Help


#8

Yellow is the current active layer. Should always be Layer0
Red is the checkbox column to controle visibility per layer.
Each layer can be turned off except for Layer0 which is (should be) active.

p.s. Layers sorted by name.


#9

I think it is crucial that everyone is aware of that link for the Layers.
I’ve said too many times myself, I should just point them to this link :smiley: