Always selecting default Layer0

Hi!

When I select one of the Layers (except Layer0) to be active and then go with mouse on project and tap any key on keyboard or middle mouse button, radio button immediately ‘jumps’ on default layer and make it selected.
What should I do to keep selected layer active?

Klemen

First of all, you shouldn’t be changing the active layer. It should always be Layer 0. Correct workflow is to create all geometry on Layer 0 and leave it there. Only components and groups get other layer tags. If you are editing a component or group, you still leave Layer 0 as active.

Keep in mind that layers in SketchUp are actually visibility tags. They are not layers to be worked on like they are in many programs. Leaving Layer 0 active and leaving all geometry (edges and faces) with the Layer 0 visibility tag means there’s no chasing layers as you work.

Is it possible you have something like TIG’s Layer Watcher installed?

Thanks, Dave, for quick answer!
A understand everything you described - I work for many years with Sketchup and this is first time I see this. Let mi be more clear:
When I select layer I wish to do with and make changes doesn’t even want to be active. ‘Black dot’ immediately makes layer0 aktive when I press any key.
So, if you understand me, I can not do anything on any selected layer.

I don’t have TIG’s Layer Watcher installed.

If you are using the proper workflow as I described, there should never be any reason to make a different layer active, though. You don’t need to make a layer active to be able to edit the contents of a group or component. In fact, since the contents of the group/component should have the Layer 0 tag, you should have Layer 0 active when you edit the group/component.

2 Likes

Why is then even possible to select other layers with radio button?

1 Like

That’s a good question. Many users have requested that it be at least more difficult to change.

Still, the correct work flow is to leave Layer 0 active always.

There is a single case that I know of where edges might be assigned to different layers. That has to do with creating toolpaths for CNC work. This is an exception to the rule, however.

1 Like

My LayerWatcher simply warns the users they have changed the current layer away from Layer0.
Nothing is forced.

That’s because sometimes having the current layer “mis-set” may be useful - e.g. you are adding Text onto a Text layer, or Dims onto a Dims layer.
But as Dave says 99% of the time it should be Layer0, as you are creating raw geometry…

My LayerWatcher also assigns Layer0 to all manually added edges/faces irrespective of the current layer setting.
And it also has context tools to reassign selected geometry to Layer0, and Explode containers, assigning any resultant geometry to Layer0 [unlike the native explode which keeps the container’s layer for any resultant geometry !]

Perhaps there’s another Extension that messes with the Layer’s settings ??
I don’t know of one ?

Also, if SketchUp was not installed/repaired properly - by selecting the installer’s exe file > right-click > “Run as administrator”, then unexpected and often very odd permission weirdness can arise - I’m wondering if SketchUp is failing to ‘remember’ the current-layer in its ‘preferences’ file because of this ??

1 Like

Becasue this issue started few days ago I was wandering why. And now that I read TIG’s post where he mentioned if there’s perhaps another Extension I just deleted one that I installed few days ago and problem is solved.

Thanks, Dave, anyway!

Thank you for usefull informations. It was realy one of new Extension I installed. Now I unistalled it and problem is solved.

It sounds to me as if you should have kept that extension to encourage proper use of layers. :wink:

I undrsand what you want to say but my way of work can’t go this way.

I’m curious why your “way of work” wouldn’t allow this.

Some background info: SketchUp layers aren’t locations in the model hierarchy, as layers usually are, but more of tags assigned to objects. For instance a group can have one layer and contain a nested group with another layer which in turn contains a component with a third layer. Thinking of layers as locations, or layers, doesn’t make sense in SketchUp as what the groups and components are located in are other groups, components, or the model root. The layer is simply something other than a conventional layer, but sadly uses the term layer anyway.

Since groups and components, not layers, define contexts in SketchUp and prevents sticking, the community has more or less reached a consensus about avoiding geometry with different layers in the same drawing context. Doing so risks accidental merging and morphing with hidden content. To get around this it is highly recommended to use groups or components for everything that is a distinct object, and apply the layer to that group as a whole.

Applying the layer to containers also allows you to go back into them and edit them at any point, without having to remember to change the active layer to whatever layer the object should use. It is also worth mentioning there is clear feedback from the program what group/components you are editing, in the form of the rest being grayed out or hidden, and the bounding box of the active object being shown. There is no such feedback for active layer.

Why SketchUp even has a control for changing active layer is for historical reasons. The rules of layer usage has been developed by the community and then gotten into the official SketchUp training, and apparently the original designers of SketchUp had other ideas of how to use layers that turned out not to be that good. I’d very much like for the control to be gone to stop confuse new users, and instead let the two or three people that have use for it in some special workflow use a plugin to set the active layer.

EDIT: Another design approach would be that the active layer only applies to inserted or newly created groups and components, not the sticky geometry.

3 Likes

My job is interior and exterior design. When I put some vegetation in project it goes on layer ‘vegetation’. So, If I want to hide it an replace it with other vegetation that is on layer ‘vegetation 2’ I can’t have it on layer0. The same stays for other objects (furniture, cars, people) etc.

Assuming your geometry is assigned Layer0 and in groups or components, then my LayerWatcher might help you ?
As outlined above you can have VEG1 or VEG2 set as current for placing component instances, grouping etc, and it’ll make you ‘draw’ any new geometry on Layer0…
Also the issue with natively-exploded geometry’s layer getting inherited from its container is sidestepped if you use the LayerWatcher context-tools.
https://sketchucation.com/pluginstore?pln=TIG_LayerWatcher

If @TIG provided the answer, you should probably have ticked that and not your response to it.

Also, if there was a rogue extension that caused the problem for you, it might be useful for others to know what it was.

I am new here: ticked means to bookmark?
Extension was 3H Furniture Tools.

Now it’s everything OK. I am working fluently as before.

No. Ticked marks the reply as the solution so others know that the problem has beeen solved and can find the answer easily.

1 Like