How to select only the geometry in front of a face?

Often I waste time trying to select only things in front of a face pressing shift and selecting the lines I need to get rid of… sometimes it works BUT some times it select all the geometry behind the face…

Try triple click triple on the face. And use the shift key to select more than one face.

That wouldn’t happen if you work with groups.

I don’t agree, instead of selecting single entities it would select the groups further back if they are within the scope of the selection.

1 Like

Your way doesn’t always work. It’s best to use the Hide rest of model command

!00% I agree, but Your way doesn’t always work. It’s best to use the Hide rest of model command

The Hide option only works when editing groups or components. So in this case it would not work since the lines, and the geometries in the back, are not grouped or in a component.

Before you start painting create an “empty” (with rectange) group/component and you’re good to go!

1 Like

As suggested by others: use groups and components more often/always!

When everything is grouped (separately) you can try selecting the geometries in front again. When you also select a group, you can deselect it more easily. (or you can lock the groups in the beack before selecting the loose geometries)