How to save a component?

If I have made a furniture myself and want to save it as a component I have right clicked and chosen Save as component. But then I don’t know where it ends up among my files. Therefor I have always saved my furniture as documents.

But when I import my furniture there is often a gigantic yellow frame around it. Why?!

It is hard to see where in the frame the furniture is, it’s not necessarily in the middle. And from today I can not see the furniture in there at all!

Skärmavbild 2021-08-31 kl. 17.13.34
If I mark a furniture, copy it and place it on another place (in same document)…


…it becomes like this. This is also how it becomes if I import the furniture from my files.

Have a look at this, it helped me.

1 Like

When I save a component it does not show up in In model.

Where and how are you saving it?

I don’t know because it does not give me an option.

I have my SketchUp in Swedish, but it only says:
General
Adaption

The standard location where the components are saved reside in a hidden folder in the user library (in Finder [menu] Go > Go To and then type ~\library)

Better practice is to create a folder in your Documents in Finder (eg. SketchUp Resources/Furniture)
and then in SketchUp, set the path to that folder in the [menu] SketchUp > Preferences > Files > Components

Then, in the Component panel, click on the blue detail icon and ‘Open or save a collection’ and navigate to that same folder.
You can also click on that icon to set it as ‘favorite’.

Do you have an option to “Replace component with selection” when saving? This would be under advanced attributes.

No. Is it because I have the 2017 version?

I think the checkbox was there in version 3, when I started using SketchUp

1 Like

Not sure I understand everything you said there… ‘Finder’ in my Mac computer, or is there something called ‘Finder’ i SketchUp?

(By the way, is there a way to change the language of SketchUp while I use it? I don’t remember how I choose the language.)

I have my folder in the Component box, but when I have saved something I can only find it in that folder when I go to it through my computer, but it does not appear in the box in SketchUp. Which is strange.

afbeelding

1 Like

This is where it is in Make 2017 for Mac.

!
!

1 Like

I have Version 17.3.116.
So it’s strange I can’t see it.

Försöker du skapa eller spara komponenter?

Om du redan har en komponent och försöker spara den så ska SketchUp fråga efter var du vill ha filen, precis som när du sparar hela modellen.

Både och egentligen. Men den frågar inte var jag vill spara den.

Beside the fact that I can’t choose where to save my components, does anyone understand why I get those huge yellow frames around a group sometimes?

I know I don’t have another group or thing inside there by mistake.

Om du högerklickar på en komponent som redan finns och väljer “Save As”/“Spara som”(?), så ska det komma upp ett liknande fönster som om du försöker spara hela modellen.

Om du bara skapar en komponent men inte sparar den så ska den synas i In Model i komponent-panelen.

Did you watch the video I posted? Sketchup automatically saves the component to itself in the components in model panel. You can create you own location to save the components but you need to copy them out of the “in model” panel to do so.

You can also just ceate a model where you can copy your favourite collection of components into and save it as another skp file anywhere you want to.

Yes I saw it, but my SketchUp does not have the “Replace selection with component”. I don’t know why.

The reason why you do not have the ‘Replace selection…’ tickbox, is because it is probably grouped, already.
But this has nothing to do with not saving or finding collections on your system.
Let’s see a screenshot of your file settings in the Preferences:


Then, open a collection: