How to remove the matched photo from the scene?

Hello Community,

I guess it’s a silly question but I just can’t find a solution.

I used a photo to build a model around it with the reference function. Now I like to remove the photo from the scene, without deleting the whole scene.

I like to get the exact same scene, just without the overlaying photo and the green tint. Please help.

Two options:

  1. Adjust the Match Photo sliders so the image doesn’t show.

  2. Create a new scene from the same position after deleting the Match Photo scene.

  1. I can’t see any slider for the opacity? How do I get to them?

  2. How do I create a new scene, from exakt that position? The only way I found to get out of the mathing modus is to move the camera position, which changes the perspective

Look under the edit tab in Styles.

Select the Match Photo scene. Click on the + in the circle in the Scenes window.

Select the Match Photo scene in the Scenes window and click on the - in the circle to delete it.

1 Like
  1. Aah thx, thanks alot, would have never looked into the styles panel for that. Strangly, when I set the sliders to zero, I still have the reference photo in multiply overlay.

  2. Doesn’t work for me. When I create a new Scene, I still have the overlaying reference photo. So I just duplicate the same scene.

Well, use step one then. You could also just untick the boxes for the images.

Thanks for your help :slight_smile:

Alot of strange behavior there. Had to uncheck the “textures mode” in the shape style panel to get rid of the multiplying photo reference.

What? The shape Style window is in LayOut.

What multiplying photo reference?

Like the Multiply Effect in Photoshop, Sketchup somehow multiplied the phototexture over everything.
For now, I found the used graphic in “used materials” and deleted it for good.

Creating a new scene from the Match Photo viewpoint when the MatchPhoto scene is still there will, in fact duplicate it…complete with image.
You need to delete the Match Photo scene first. Just don’t move your viewpoint until you’ve created a new scene.

When I delete the Scene and create a new one, I get the same scene, WITH the photo. ANd I can’t see a way to exactly delete the “MatchPhotoScene”, because SketchUp treads it like a normal scene.

1 Like

That’s strange, because the method I described is exactly how I removed the Match Photo from the file in this thread and replaced it with a small portion of the same image from the same viewpoint.

Yeah, I replicated your steps, but for me the photo was still there and I got the same scene again.

1 Like

Even in SketchUp 2021 this is still and issue. One cannot get rid (delete) of the Matched Photo from the scene. Luckily you can create Custom Camera with FredoPortrait. Delete the Matched Photo Scene. Load the FredoPortrait Custom Camera and add it as a SketchUp Scene.

You can delete the scene with the photo in (the one that says match photo in the top left)
This will get rid of the image.
immediately create a new scene.

You now have the same camera setup and no photo.

Or as dave said, just disable the foreground/background photo in any style you use.

Hi, click on the zoom button, look the value of fov at the bottom right, type slightly different value (with dot, not comma) and hit enter, picture will be gone, after that type the exact fov value and hit enter, save as a new scene… Using dot as seperator is important… You can check two scene, they are the same, you can delete the first one…

Well, if the issue is that you want the camera point of view from Match Photo, but without seeing anything of the photo, I’m with @DaveR. It’s standard operating procedure for me to want it both ways, so I save at least one Style with Match Photo turned on and at least one Style with Match Photo turned off. When I composite a model into a photo, I want to do it in Photoshop, so I want to export just the SU model without any of the photo to use as one layer in PS while bringing the photo in as another layer (or two actually) directly in PS without passing through SU. That’s why I often duplicate Match Photo scenes and save them with different styles, one with photo on, one with photo off.


That said, Match Photo scenes are a bit sticky to work with. I’m not getting the other tricks to work, really. Any time a new is created after being in a Match Photo scene, it inherits Match Photo behavior. The only saved scenes in this file are Match Photo scenes, and it seems it is now impossible to create any new regular, non-Match Photo scenes. That’s a really odd corner to be backed into.

Have you tried the way i wrote?

My first attempt last night didn’t work. I tried again today with a newer, simpler file and it seemed to work OK. Unfortunately, I don’t have a lot of time to play around right now.

1 Like