How to reduce file size?


#1

Hi! I’m using Sketchup 17. Right now working on project with a big garden, I uploaded there lot of components (trees, bushes etc) and i saw that my file is huge- 700MB! Does anyone have any advice what to do? I cant work on it because it’s not responding all the time.
I am not very good at using sketchup, just started half a year ago so please understand.
Thanks!

PS
I finished modeling, but I need to use it only for an hour to make renders


#2

Um, yea, that is huge!
I can’t say I blame your computer for not responding. :smile:

If there are a bunch of components that you downloaded but decided not to use for some reason, you can try purging the model by going to Window menu >Model Info>Statistics>Purge Unused.

I think there may be plugins for reducing file size, I’m not really familiar with very many plugins.

But my strongest advice is for you to try to use only low-poly components from the Warehouse. I know there are some beautiful landscaping items available, but most of them are far too big to be practical in a “big garden.” Many of the simple, smaller components will do the job, if you choose carefully.


#3

Many components from the 3D Warehouse, especially attractive and detailed foliage, have outrageous edge and face counts that will severely bloat your model. As @MobelDesign suggested, try to find simpler ones. Or, consider using simple “proxy” components while editing the model and then swapping them for the beautiful but heavy ones only when you need to render. There are extensions available to help swap between proxies and final components (sorry, on my phone so can’t look up a link right now, but search the Extension Warehouse and SketchUcation plugin store and you’ll find some).


#4

Try following the advice on the attached url link: HOW TO MAKE SKETCHUP RUN FASTER. Look at the other items featured on the SketchUp Sage site as well.


#5

In your free time could you send me some examples of these extensions? I was looking for something but I’m not sure what to choose…


#6

Turn off your shadows to make it run faster.


#7

Right now it’s quite ok. I turned off edges, shadowed, I purged the model. Also I made a component of all the plants ,I saved it on my drive and I deleted it from model, thats why It’s working now. I have a plan to prepare scene, settings and at the end upload that ‘plants component’ and render. Hope it will work.


#8

Here are a couple:

https://sketchucation.com/plugin/772-proxy

https://extensions.sketchup.com/en/content/eneroth-component-replacer


#9

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.