How to Preserve Section Cuts for Scenes?

sketchup
#1

Hi Folks… got a client breathing down my neck and need an expedient fix. Thx in advance for your precious attention and time!

Set-up: I am creating scenes for Basement, First Floor, Second Floor and Roof Plan. I set my section plane appropriately through the whole house model I’ve built to see each plan (no section plane for roof). I get everything beautiful, update the scene and save the file (for each scene).

Problem: I click on the scenes I’ve created and they’ve reverted to the section plane location of the scene before! Doesn’t matter if the “Active Section Planes” in Scene Properties is checked or unchecked.

So, in summary, whatever plan I’ve set up last (say First, for example), when I go back to Basement or Second, they are both now the First Floor!!! Ugh! <little voice crying “help!”> The image below shows the First Floor in content for the Basement Scene… I cannot find a way to preserve the section cuts for each scene.

0 Likes

#2

According to your screen shot you have unticked Active Section Planes in your Scenes panel meaning that property won’t be saved when you create or update the scene.

0 Likes

#3

Thx Dave,
I’ve tried it both ways. Same results.
Scratching head,
Billy

0 Likes

#4

Do you have it ticked in Properties to Update?

Share the SKP file and we’ll look at it. I’m just heading out but will look when I get back if no one else does before.

0 Likes

#5

Checking…

0 Likes

#6

Okay, thx. Maybe I don’t have that feature in SketchUp Pro v16. The pull-down for each scene tab has the word “update” but does not have on/off check marks (ticks). I just click on the word and assume it’s updating properties.

File was too big to upload (68MB).

0 Likes

#7

You have the feature in SketchUp 2016. The Properties to Update list appears when you update the scene from the Scenes panel.

0 Likes

#8

0 Likes

#9

Thx Ian,

Just trying that now. I’d been trying to update from the individual scene tab.

Fingers crossed,
Liam

0 Likes

#10

This is making me ill (or maybe it was all that holiday food). Doesn’t work. No matter what the setting or update path, the scenes all automatically revert to whatever section plane was used in the last scene updated.

0 Likes

#11

Wait, just to double check: “section plane” singular or plural? Do you have one section plane that you’ve moved for each floor level, or did you create different section planes for each floor level? It should be the latter. That could explain the problem otherwise, yes?

This example shows two floor plan sections plus a ceiling plan (looking up), not to mention two vertical sections:

1 Like

#12

Hi Ian,
Just a quick follow-up. A Community member caught that I was moving my section plane rather than using multiple section planes. That’s the problem. I get it now.
Happy Holy Daze!
Liam

0 Likes

#13

Hi Dave,
Just a quick follow-up. A Community member caught that I was moving my section plane rather than using multiple section planes. That’s the problem. I get it now. Thx again for your kind effort.
Happy Holy Daze!
Billy

0 Likes

#14

RTCool,

That must be the problem! I thought saving scenes without updating the shifted cutting plane would save the old cutting plane location. How do I tag the cutting planes like you did? Wow, nice.

Cheers,
Liam

0 Likes

#15

Just use the section tool to make new sections planes. You can name them … to a point … only three characters, if I recall correctly. I have 1F, 2F and 2C there for 1st floor, 2nd floor and 2nd floor ceiling. You can double click on any one of them to make it “active”, and that check box for a scene remembers which section plane is the “active” one for that plane.

If that’s the answer to your problem, check the solution box on my reply above as the solution.

1 Like

#16

Hi @ruahaus, glad with @RTCool 's help your identified your solution.

For my modeling, I created a template of pre-existing Section Planes (3x East/West and 3x North/South), floor plan cuts (3x), and reflected ceiling plan cuts (3x), which I reuse over and over with different models.

I also take another step with my Section Planes. As they are an object like a group or component, one may assign them to a Layer. In my template I have 12 Layers already set up with each respective Section Plane assigned to it. I can then turn on the visibility of the Section Plane I am interested in moving, reorienting, enabling Active Cut & etc. (with the balance of Section Planes, visibility, turned off) to help my modeling.

Here are my Layer names:

Section%20Layers

I then name my Section Planes similarly to my Layer names in the manner that RTCool notes above when creating a Section Plane or through the Entity Info panel or Outliner panel (right click on Section Plane name) if the Section Plane already exists.

0 Likes