How to open a 2015 sketchup file in 2017 version of sketchup?


#1

An architect is trying to email me a sketchup file made in 2015 version of sketchup, and I’m using 2017 version, so I can’t open it? What can I do?


#2

You can open it like any other SU file.

You will get a message that it will be upgraded (i.e. Your architect will not be able to open it, as it will now be a 2017 file), but no extra work on your part!


#3

The warning only applies if you save the file without doing a save-as and selecting 2015 format.


#4

Have you actually tried opening it in 2017 using File/Open? (If you get the warning that it is an older version, dismiss it).

And if you make any edits, and need your architect to be able to open and edit your amended file, do as Steve Baumgartner suggests - use File/Save As and choose SU 2015 as the file type to save.

If you can’t open the 2015 file in SU 2017 at all, there’s something wrong - probably with the file, possibly with your installation of SU, thought that isn’t very likely.


#5

Thank you so much. That’s what I thought, that I should be able to open an older version, and that likely the file was not saved or shared properly.


#6

When I go to open the 2015 file from 2017 version of SketchUp, it opens but there is nothing there??? Very strange.
One note, every attempt the architect has made to send me the .skp file, once I download it the file size is 0 bites.t


#7

Pretty clear evidence that the transfer is not being done right, but impossible to say why from afar!


#8

Try to let him Zip the file and then send to you.


#9

Is there a simpler, more universal file format for the architect to export the file out of their version of SketchUp before they send it to me such as a special file format that my 2017 version will be able to open?
It also seems really strange that the file attachment is arriving as zero bytes in, but there is a specific file name.


#10

The best format for saving a SketchUp file to be opened in another SketchUp file is the native SKP. Perhaps he could try uploading it to DropBox or to the 3D Warehouse and provide you with the link.


#11

Are you and the architect both on Trimble Connect?


#12

Before exploring other formats, there are a few points on which to be absolutely clear:

  • There is no reason why SketchUp 2017 can not open and read a valid SketchUp 2015 file. The version difference is not the cause of your problems.
  • It is quite possible that the problem is with user error (e.g. the architect is actually sending a blank file) or with a communication issue that is killing the attachment. Exporting to a different format is not likely to alter these issues.

I can think of a few ways a file could come to have zero size yet have a valid-looking name (and there are likely others). Your architect may have actually created a zero-byte file on his end and sent it to you by mistake. Have they checked the file they sent? There may be a problem with the email channel, which has a lot of working parts - their email client app, their outgoing email server, your incoming email server, your email client app - any of which could potentially lose the file content. For instance, there may be a size limit for attachments. Have you sent other files successfully via this channel? There could also be a problem with a virus or spam trap deciding the file is dangerous and killing it. SketchUp files are not so well-known that such filters are certain to recognize them as safe (they are opaque binary, not text, so in theory might contain a virus even though they are not executable per-se).

Finally, as others have suggested, I’d try a different channel such as 3D Warehouse, Trimble Connect, Google Drive, DropBox, etc. before trying a different file format.


#13

Having worked with AutoCAD, ArchiCAD, Lumion, and having had to open Revit, OBJ, 3DS, and more files over the years, I can safely say SketchUp’s native .SKP is the simplest to use and share 3D file format I’ve seen. Even when opening really old .SKP files, you don’t have to worry about conflicting or absent libraries, XRefs, missing textures, things being moved around, or the drawing being done in different abstract “units” (I’m looking at you, .DWG).

What you describe seems to be a file transfer error. Try WeTransfer. I use it all the time with my clients.


#14

Thank you so much for your help. Problem solved. The architect was simply not attaching the file properly in his email program.

Sincerely,

Warren Gibbons, Owner

Gibbons Aquaria, Inc.

wgibbons@gibbonsaquaria.com

781-760-7219


#15

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.