Can't open my very old (but important) sketchup file (Unexpected File Format)


#1

Hi everyone, this may be a long shot but I recently received the dreaded unexpected file format error message and can no longer open a very important file. Here is where it gets a bit tricky: the original file was created on an older version of sketchup (I believe it was 2014), and now it will not open. I also tried to rename the .skb file to .skp and open it but no luck. It is a complete model of a downtown area and took probably over 50 hours to create several years ago when I was doing my masters thesis. I backed up the file at that time and never came back to it. Is there any possible way to retrieve the file?

Thank you in advance to anyone who helps (or tried to help).

Regards,
0 - Copy.skp (1.7 MB)


#2

try downloading the version you created it in… I tried it in 2017 and 2018 with the same result


#3

I tried in 16 as well and no luck. Interestingly I can see the Icon preview which shows the sketchup cityscape, so it was once a sketchup file. But this is only 1.7 mb which sounds small for 50 hours of work, unless it was a relatively simple collection of untextured rectangles I would be suspicious that this is a corrupted file.


#4

No joy using SU 2014 either.

Shep


#5

I tried to open the file in a development version of SketchUp - the file cuts off in the middle of a texture. It looks like the file was truncated or damaged at some point. I’ll ask around the office tomorrow to see if there’s a way to do a partial recovery.

-m


#6

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.