How to not mess up existing scenes when creating or importing layers?

I need some help solving a problem that’s dogged me for a long time.

I have established scenes which I use to generate LayOut drawings.

If I ever create a new layer or import new layers into that SU file, the SU default is to have the layer turned on rather than off. This is a major hassle because it essentially corrupts all the scenes I created previously by turning on unwanted layers. I must then edit each scene and turn off the new layers. This is a pain.

Can someone help me know how to have new or imported new layers default to OFF?

  • Thanks heaps, Fred

I don’t know of any way to prevent layers from being visible when they are imported with components but there are some extensions that will allow you to create new layers that are invisible in existing scenes. Auto-Invisible Layer is one.

What version of SketchUp are you using? What graphics card? Please complete your profile.

Thanks DaveR. That looks great. I’ll try to install the extension. I’ve lived without extensions for a while, but I definitely need this one. Much Appreciated. - Fred

Hi Dave,
Had two further questions.
First, the extension is not explicitly compatible with SUPro 2018.
Second, the extension is not signed.

What are your thoughts about trusting it?
-Thanks, Fred

As for working with SU2018, I guess give it a try and see. It works fine for me in SU2018. It can always be uninstalled. There are alternatives, too. The Unsigned thing is not really an issue unless you set loading permissions to prevent unsigned extensions from loading. It’s worth using some caution regarding this however in this case, there won’t be a problem. CMD, the author, is a trusted extension author.

Hey @FredsTinyHouses, I’d like to suggest a workflow that doesn’t involve an extension (although that one by CMD is still a good option for you). The accompanying image might be enough info, but here’s a bit more about this method if needed:

Example: I have 13 SketchUp Scenes in a model where I haven’t yet bothered to adjust any of the Shadow Settings to lighten or darken the feel of the space. Now I decide I need to adjust the Shadow Settings (while in Scene 1), but I don’t want to go to the remaining 12 Scenes and manually make this update one-by-one. :confused: No worries… I can just shift-select Scenes 2-13 and bulk-update those simultaneously by clicking on the Update button in the upper left of the Scenes panel (circular arrows) and unchecking everything except “Shadow Settings”, and then clicking on “Update”.

This is the same process as your situation with Layers, you’d just selectively bulk update a bunch of Scenes at once by unchecking everything except “Visible Layers” after turning off your newly-created Layers. If the aforementioned extension works well with your issue, what I’ve described here will still come in handy when you need to swiftly update other properties in existing Scenes.


Good hint, thanks. I had been using the Auto-Invisible Layers extension, but while it worked on SU2018, is does not on SU2019. This method saves a lot of time in the event you create a new layer and forget to turn on Auto-Invisible.

OOPS. Spoke too soon. The technique you suggested will make all selected scenes have an identical layer structure. This is not at all what I need. I just need to be able to add a layer late in the game without having is show up in all the scenes, without messing up all my other scenes which contain many layer combinations.