How to Keep Preferences from Changing when Opening a New File


#1

Hey Guys,

I’ve always had this issue but now it’s actually starting to annoy me. I can open up SketchUp on either my Macbook or the Desktop at work and generally all the preferences from the last work session have reverted back to defaults. One example of this is the toolbars for various extensions no longer appear at the top of the window. Another is the Keyboard shortcuts that I’ve created over and over again go back to the defaults, most of which are blank.

Is there any way to make sure these things stay the same everytime I open SketchUp? Could it be that I have to save a blank file with all this stuff as a default template?

Also, on a, sort of, unrelated note. If I have the preferences to Auto-save every five minutes why is it when SketchUp crashes the most recent Autosave is 2 hours prior?

Thanks,

T.


#2

You said it yourself. Create a blank file with things just the way you like them, then save it as a template and make it the default template.


#3

Per the Forum Guidelines, this “unrelated note” likely should have been it’s own topic.


#4

If your shortcuts are being reset and your autosave isn’t accurate it sounds like you have some faults in your installation.
However, as I have no experience with mac I can’t offer any advise other than try to reinstall/repair.


#5

Toolbar positions and display state are not part of the templates. Their locations are saved in a different file. In the Registry on Windows and in a plist on Mac.


#6

That is unusual behavior. Your toolbar positions and shortcuts should persist, and you should not have to save a template to achieve this. You might try sketchup>preferances>workspace>reset workspace to clear up toolbar confusion, then set up as you like and hit save current window size in the same place.

But it’s possible these two issues are actually related. These behaviors could be symptoms of sketchup having inconsistent access to the library or application support folder, (MAC-library-application support-sketchup version-autosave). If sketchup was unable to access the library for some reason then preferences and autosave would not be able to update. Are you logging in as the same user each time? This could be a disk permissions problem. Might be worth running disk utility app to see if there are permission issues that need fixing.


#7

Yes. DaveR’s post is correct. If I open a blank file and set the shortcuts and toolbars I want then close the window SketchUp will preserve the settings for future files. It’s a little weird that this is how it’s achieved. It still misses a few shortcuts but the Toolbars are all fixed.

Thanks for the help guys.


#8

Keyboard shortcuts should be saved when you make them but keep in mind there are OS hard coded shortcuts. If you try to use them as custom shortcuts , the OS will override your setting.


#9

On a Mac, the toolbar positions and states are saved in the main SketchUp plist file

~/Library/Preferences/com.sketchup.SketchUp.2017.plist

And your keyboard shortcuts are saved in

~/Library/Application Support/SketchUp 2017/SketchUp/Shortcuts.plist

(Note: the leading ‘~’ is shorthand for your user home directory. These files are not in the system’s /Library folder, nor are they anywhere inside the app bundle.)

If SketchUp is losing your toolbars and shortcuts, it suggests that there is a problem writing to these files. You could take a look using Finder’s Get Info to verify that you have permission to write to them. It would be very strange for you not to have permission, but the problem you describe is also one I have never encountered, so I’m just taking a guess.

Unlike on Windows, there is no right-click->Run as Administrator when installing on a Mac, so that can’t be the source of your problems. But another idea: did you install in the standard way by opening the installer .dmg and in the installer window, dragging the SketchUp icon onto the Applications folder icon?


#10

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.