How to export 3D SU building model to 2D dwg file with NO hidden lines

Have been looking all over for this seemingly simple issues.

I have a 3D building model in SU. I want to get 2D straight on facade views, or elevations as we call them of this building into Autocad without all the hidden lines. Using the file/export/2D graphic/dwg menus SU Pro 2014 has to offer gives me the AutoCAD file BUT with all hidden lines showing (wireframe), meaning all items behind the exterior walls are also visible with no distinction between hidden or visible lines or edges.

I thought a while ago I was able to get crisp 2D CAD files from 3D SU models easily, but don’t seem to be able to reproduce it.

Your help is very much appreciated!

Check your styles, it sounds like you have it changed to either wireframe, or x-ray or back edges shown or something along those lines.

No, using Hidden Line, Shaded or the other two “solid” styles all giving me the same wireframe type look in CAD. The hidden line drawing on the screen is what I want to get into CAD.

Is there another setting somewhere about hidden lines that I might be missing?

Those styles that we’re talking about is under 'Face Styles’
Try the ‘Styles’ window, under Window->Styles (on a mac)

And I’d suggest you upload a screen capture of what you exported so maybe we can try to figure out which styles or settings you’ve turned on to get that

Thanks for pointing that out. Attached is a screenshot, hope it may shed some light on this.

well…everything looks fine to me, so I dunno :stuck_out_tongue:

Thanks for trying, appreciate it! Playing around some more I discovered that if I open a new drawing and try to export using a newly drawn simple model I get the desired hidden line/non wireframe 2D CAD file. If I insert the drawing shown above in a new file nothing changes, I get the same wireframe result in CAD,

This seems to be a graphics card OpenGL issue - probably, for you, it kicks in when the model reaches some complexity. You might try upgrading your graphics card driver, or turning off Hardware Acceleration (Window menu>Preferences>OpenGL) and restarting SketchUp before exporting.

Anssi

1 Like

Fantastic! As you suggested Anssi, turning off the Hardware Acceleration did the trick.

Thank you for your help!

5weigels,

I still recommend that you try upgrading your graphics card driver. Zooming and orbiting with complex models is slow with Hardware Acceleration off.

Anssi

Anssi, are you referring to updating my graphics card driver? Not sure how I could upgrade the driver, as opposed to the graphics card itself?

I could also turn Hardware Acceleration off once done since I have never come close to performance limits even after working with quite a few complex models. Maybe there is some particular complexity to this one for some reason that makes it more demanding.

Thanks!

5weigels,

Upgrading the driver usually means going to the website of the manufacturer of your graphics card’s “chipset”, usually Nvidia or AMD(formerly ATI), downloading the latest version that is compatible with your card and then installing that, If you rely on an Intel integrated graphics chip instead of a distinct graphics card, upgrading might not help.

Anssi

Anssi,

First I did the obvious and searched from within Windows for a newer driver software update. ( AMD Radeon HD 7850m)

Thanks to your instructions I then tried the upgrade but unfortunately it messed up my resolution/displays (two monitors attached) completely. Without being able to make it work with the upgraded driver software I was glad to be able to reverse the quite substantial installation and got my old settings and driver back.

Unless I can figure out within a reasonable time-frame what I did wrong I better leave the upgrade alone and just turn Hardware acceleration on and off as needed.

Thanks again!

i had the same problem, thanks for asking and thank to Anssi for help.

Try this: http://extensions.sketchup.com/it/content/skema-2d-projection maybe should help you in future

Guys, many thanks for asking and answering. There is only two days left to my final exams and the solution saves my life!

Thanks for this. This acceleration disable trick, worked on my sketchup.

For others: This is an old thread. Note that SketchUp versions from 2017 on no longer support software OpenGL and an OpenGL-supporting graphics card is a requirement. So you won’t find a Hardware Acceleration checkbox in the Preferences>OpenGL dialog.

Today, still, some graphics drivers require either disabling or enabling the Fast Feedback feature on the Preferences>OpenGL dialog (generally, Off for inegrated graphics, On for discrete graphics “cards”).