DWG/PDF export shows too many lines


#1

Hello,

I am having an issue with exporting my sketchup to 2D. I want to export my view from SU, but the created file shows all lines that are ‘behind’ this view too (see images for clarification). I have already searched the forums and tried to turn off hardware acceleration, it didn’t solve the problem. Also, in the export options, I tried turning on the ‘seperate on layer’ option for both profile lines and section lines. Yet, everything appears on layer 0 in Autocad.

What else could be the solution?

UPDATE: apparently, when I hide a couple of items that I don’t want in my export, there is a certain point where suddenly this problem stops occuring; the export then only contains the lines visible in my viewpoint. When I unhide these items again, the problem returns; suddenly all the lines that are in image appear in the 2D export. Seems as if it is a hardware problem?


#2

Did you restart SketchUp after unticking “Hardware Acceleration” in Window menu>Preferences>OpenGL?
Have you tried updating your graphics card driver?
Have you tried printing to PDF with a PDF print driver?

Anssi


#3

Thank you for your reply! Yes, I did restart SU after tcking off hardware aceleration. About the graphic drivers; I forgot to mention that I use mac OSX, I am on the latest update so drivers are as up to date as possible too for a mac. I have not tried to print to pdf, but the biggest issue is actually the DWG, because everytime I need hours of work to clean up in Autocad.


#4

to export as 2d, remove all the unneeded groups from the skp first, it’s quicker than removing the lines later…
you can copy/paste the one you want into a new drawing first…
I looked at using the same model in a project years ago, but ended up downloading a dxf blueprint from somewhere, and made my own version…


#5

Thank you too for your reply. Removing the groups isn’t a solution either, but a temporary workaround. It would be nice if it was possible to export just the sideview/frontview etc to 2d…


#6

UPDATE: apparently, when I hide a couple of items that I don’t want in my export, there is a certain point where suddenly this problem stops occuring; the export then only contains the lines visible in my viewpoint. When I unhide these items again, the problem returns; suddenly all the lines that are in image appear in the 2D export. Seems as if it is a hardware problem?


#7

It looks like you’ve exported using the ‘3d model’ option rather than ‘2d graphic’. Both can export DWG but if the 3d model option is chosen you will get all of the geometry including the non visible elements. If you choose 2d graphic you should only export the geometry that is visible. I’ve never known it to work otherwise.


#8

@Kenny, it is a 2d graphic Export that’s failing for @jasondijkhuis
I get the same outcome on my mac as well for either dwg or dxf…
It’s also on any model not just the VW_Samba.skp from 3d Warehouse shown in the first post…
Are you also on a mac?


#9

I’m on Windows. I didn’t realise that this was an issue with a mac.

Have you reported it to Trimble?


#10

@Barry, @tt_su can you have a look if there’s a bug pending for this behaviour?
john


#11

Good to hear that I’m not the only one and this is a common issue, hope that this will be adressed as a bug


#12

Hello

I had the same issue and I’m running SUpro15 on Windows. I had the probelm with drawings with a lot of edges. I disabled the graphic acceleration and then it worked:
Windows/Preferences/Open GL

Hope it helps!

Samuel


#13

I am having a similar problem. I have used sketchup pro8 to export building elevations and plans to DWG/DXF in the past with no problem, but now, using sketchup pro 2014 / 2105 all hidden lines are exported. At best this severely limits the use of the exported files in other cad packages and in many cases the exported file is of no use. I have been unable to solve this problem and have reverted to SUpro8 to export DWG/DXF files. I run a very busy architectural practice and have been using sketchup every day since 2003.


#14

Please fix this horrible bug, the 2D exporter via DWG is not working. Lines need to be hidden when exporting correctly, not redrawing everything. This has been a problem since 2015, SU Pro 8 doesn’t have this issue. It also occurs when you transport the model to vector mode in Layout.


#15

It is not a bug. It is an OpenGL problem with your display driver. Try updating the driver, or, if that doesn’t help, turn off Hardware Acceleration in SketchUp (Window menu>Preferences>OpenGL) and restart SketchUp. Since version 8, SketchUp has intensified its use of the graphics card to improve performance.

Anssi


#16

ok thank you… onboard graphics really suck


#17

I was running into this issue as well and think I figured out a solution after messing around with it for a while. I was trying to create interior elevations on a hospital project and kept getting every line in the model rather than the elevation with lines hidden beyond.
I discovered if I set up the View using the section tool first rather than the standard orthographic views that it would work and properly hide the iinformation beyond.
So for instance on the VW van rather than just clicking on the side elevation button you would actually set up an active section view out in front of it.
Give it a try I’m playing around with it a little more and it seems to work on extremely complex models.


#18

Hello, we have same problem. And I have fix it. Just try to turn off the hardware accleration. If it doesn,t work, try to EXPLODE the file you want to convert. Make sure that all of the components and groups are exploded. Then try to Convert your file again.