Error when exporting to AutoCAD (.dwg)

dwg
error
sketchup
export
autocad

#1

Hi. All
Can anyone help me resolve this issue I am getting when I export from SketchUp 2017 to a .dwg file.
When I export my 3D object from SketchUp as a .dwg and open it in AutoCAD all the lines are red and there is a copy of each line directly on top of each other. (2 lines in the same spot). I have exported as a .dwg file in the past and when I have done it before my objects had white lines in AutoCAD and there was no copy of each line. My issue is that when I send these files to have my stuff laser cut they cannot use the file as the laser cutter cannot read the dimensions.
I have some pictures in this album which show my problem. http://imgur.com/a/lsIeF

This is how they look now.


#2

Could you share an example of a skp file that has this issue? That way we can see whether we can reproduce the problem and also analyze whether it results from some aspect of the model. Thanks.


#3

Here is one of my file that has the issue. This problem also happens with all my new files.
Endplate_1.skp (92.5 KB)


#4

I believe that the ideal method for output is to export as a 3D DXF file, and turn off everything but Edges.

That should give you a File with only one set of lines (the second set is probably the lines that outline the surfaces in your model).


#5

I have tried .dwg and .dxf as an export. The image below was exported as a .dwg without any groups or components. This file has no issues. Though whenever i try exporting a new file or an existing one I get this issue. even if I add to the file below which I exported I get the red lines.


#6

I found that if I set options for the export to do only edges or only faces that the result was clean, but if both were on the dwg got both the smooth true curves and the segmented SketchUp representation! This seems like a bug!


#7

Which option would you suggest I turn off here.


#8

That is correct. Cad sees edges as lines and surfaces as faces with lines around them.

This is why I recommended exporting a 3D DXF/DWG with only Edges enabled.

I just tried with your model and it seemed to work just fine.


#9

I have set the export to only have Edges enabled and the double line error is fixed, but is there a reason that my lines are still red in AutoCAD.


#10

I am guessing that it is drawing your lines the color attributed to your layer (default color for Layer0 is red). In the Layers window, click the red swatch to the right of the layer name and you will get a flyout that will allow you to change the layer color.


#11

Ok. I wasn’t sure if AutoCAD was detecting an error or not. Thanks for the help guys.


#12

SketchUp faces are translated into AutoCad Polyface objects. Like their SketchUp equivalents, they are defined by vertices and straight edges between. If SketchUp exported Surfaces that are delimited by NURBS curves, this problem wouldn’t exist, but SketchUp is not based on NURBS.

Anssi


#13

This topic was automatically closed after 91 days. New replies are no longer allowed.