How to avoid unneeded extension lines?


#1

If i do measurements inside of an object, i often get extension lines, where i don’t really need them. Often, they are covered by the lines of the entity, so no problem.
But sometimes the extensions extend into blank parts, and i need to shorten them manually…
Am i doing something wrong? As there is some smartness in the way the dimensioning-tool adds extension lines, i would expect it would leave them completely, or make very short, if it sees they are not needed…


Can't see dimension connection points
#2

Do something for me. In a new LO file, draw a line and then place a dimension above it. Don’t screw around with it. Just place the dimension and leave it alone. Then upload the LO file.


#3

Here we go…
dimension-tool-test1.layout (8.5 KB)


#4

So from your video and from your other post about extension lines, it appears you have the extension line set to be quite tall. In the LO file you shared, the End Arrow size for the extension lines is set to 5 pts. Is that what it is in the dimension in your GIF? Or is it set to something larger? For my templates I set the End Arrow to 2 pts because I don’t care for the long extension. Maybe that would work for you, too.

In any case, for a given template, you really shouldn’t need to be editing that setting. Make it once for the template and leave it alone.


#5

Thanks dave…
Yes, that was (part of) the problem. But i don’t actually remember to have ever changed that setting, i would have thought that was the default ones.
So for anyone else looking for that post with the detailed solution, it’s this here:

But for the post- title, i still would expect LO to reduce the extension lines to zero if they are not needed. Because in the example in the gif, even with the extensionline end arrow only 2pt, it still extends into the chimney, and i have to move it manually.