How to avoid creating hidden lines from intersecting shapes

I recently changed to Make 2017 from 2014 and it seems that I have more errors from intersecting parts of the model. After combining there are many hidden stress lines on otherwise flat faces. I no longer use intersect and have been manually combining the faces by adding the individual lines by hand, Or I remove the entire face that will show the stress before I intersect and then have to manually rebuild the faces. How do I stop this? Or is a newer Make version better? It also tends to pick a pint NEAR the corner but not the actual corner, so I need to zoom way in to check.
Thanks all
Socrates

It would help other users to diagnose what is happening if you can upload a small sample model .SKP file into a new reply. Drag the model file into the reply, or use the icon that looks like an up-pointing arrow to upload a file.

My guess is that the geometry has small edges, or has faces that are very nearly co-planar. If that is correct, you could try the “Dave” method of putting the geometry into a component, making a copy of the component, scaling up the copy by 100 or 1000 times, and then performing the intersect and cleanup on the large copy. Delete the large copy when done; the original normal-size copy will “inherit” all the edits. This process generally avoid’s SketchUp’s inability to handle very small-scale geometry.

Without seeing the actual file (as @TDahl has suggested) it is difficult to know what is going wrong or why. It sounds like typical problems associated with the inherent “sticky” nature of SU geometry which is usually associated with drafting techniques. Appropriate use of groups is usually needed to avoid this as it suspends the stickiness of raw geometry outside the group.

ungroup and intersect.skp (149.8 KB)
Thanks, couldn’t figure out how to attach it…
Just ungroup and intersect and the small face shows stress lines as well as the sides.

I usually work at 100x scale and then scale to 0.01 before exporting the .STL file
This is at printing scale 1:1

SketchUp’s handling of faces that are just a tiny bit non-planar is sometimes erratic. It may accept a face as planar when the corners are very slightly out of plane and then during a later operation decide they weren’t close enough after all. That is what is happening in your sample model. No doubt the sloping top edge causes SketchUp to recalculate planarity.

If you carefully inspect the corners of the near face of your wedge component, you will see that they are slightly askew. The green axis values at the top are not the same as at the bottom.

1 Like

Thanks! The 2017 Make seems real finicky about where it puts a point and picks non edges often. Is there a better version of offline I should use? Seems that 2014 was better at this, but had similar issues, just not nearly as often.

Would Eneroth’s “Flatten To Plane” extension correct this?

Maybe. But ultimately anything that involves a calculation (e.g. finding a good plane to flatten to) will inevitably encounter computer arithmetic limitations and risk tiny errors.

The best approach would be to pay very close attention while drawing the model in the first place. For example: lock to the blue axis while drawing vertical edges; type in values instead of just clicking in space; wait for an inference when starting or ending an edge against another existing one.

3 Likes

Is there a “best” version of the offline Make? Especially for this kind of thing. 2014 seemed to grab corners much easier than 2017 does. I’m making jigs for model train tracks with lots of curved things and can’t place the pieces, they fall where the cross ties fall. So there are many intersections performed if it works better. I’m finding it easier to hand trace the intersections rather than use intersection now.

The only version of Make is 2017. If you need to run on the desktop or need extensions that is the only free Non-commercial choice. It is, however, frozen and not getting updates. The free web version is kept current via frequent updates, but can’t run extensions.

1 Like

Following these rules, is it still possible on small dimensions to get non-coplanar edges/faces due to SU’s inherent accuracy?

Setting user error aside, small errors naturally creep into coordinates whenever SketchUp has to calculate the location of a vertex. This is unavoidable because computer arithmetic can’t get an exact result for every calculation due to limited precision. It happens even on objects that aren’t tiny, but becomes critical when the model is small because SketchUp has a tolerance to attempt to manage numerical issues. When the errors are comparable to the size of things in the model, chaos may result.

Some examples of unavoidable calculations subject to error:

  • In general, to find the intersection point of two edges, SketchUp has to solve using the line equations for the two edges. When an edge is parallel to an axis, so that, say, its x value is constant, SketchUp can dodge calculating it and simply copy it to the intersection’s x. But in general, a calculation is required, and that generates numerical error.
  • When creating a circle or arc, SketchUp has to calculate the positions of the vertices using the center, radius, and number of sides. Typically only the cardinal points will be at “nice” locations, and that only if the user dragged along an axis while creating the circle.
  • Computers work in finite binary math. But most of us don’t specify fractional lengths that have nice exact finite binary values. For example, 1/3 has no exact finite representation either in binary or base 10. And only a few decimal fractions have exact finite binary representations. So, when you type a length as 10.4 cm, that 0.4 part gets captured as some binary value that is just a tiny bit off. As these values get used in additional calculations, the imprecisions accumulate and can become important.
1 Like

Is there a way to clean up the stress lines automatically? A plug in maybe? I just hate dealing with them and manually erasing them.

I couldn’t get your example model to show any stress lines, but still you could try the extension that sWilliams made, here:

The file you download is sw_flatten_to_calculated_plane.rbz. Install that, then select a set of faces and edges that are supposed to be coplanar, but might not be, then choose the extension in the Extensions menu. It may prevent stress lines from occurring, or get rid of them if they are already there.

Doesn’t the web version lack considerable functionality compared to Make2017? Inability to add from the Extension Warehouse is one that was the deal breaker for me.