How do I get rid of/ avoid getting these weird lines...?


#1

How do I get rid of/ avoid getting these weird lines that trail off from my shapes? Here’s a pic.


#2

It looks like you have several hidden lines in your model, those trailing off and a few in the surface to the lower right. Go to: view>hidden lines and see if lines show up. If so, you can delete the trailing off lines. The lines in the surface to the lower right appear to be there because the surface is not co-planar and could not fill in without these lines. Thus a thought. Hope this helps.


#3

Hi Paul, I understood your reply to the OP, but a thing I’ve noticed is that for instance you intersect a fully honest-to-goodness plane with say a prism, and when you later open the drawing again the original plane has been somehow distorted and is no longer co-planar, SketchUp having introduced “intermediate” lines to maintain continuity as in the “brick” on the right. SU has the habit of developing this type of distortions, and also of microscopically dislocating edges end points according to it’s own will. Many are the times I have to review drawings because I have to take pains to correct geometries, causing irritation and major waste of time. Have other people complained of the same? Thanks!


#4

@lenlenlen1

Did this model originate from a cad import?

At some point did you move the main feature from left to right? If yes, how did you go about moving the feature?

Please describe your modeling process as hidden linework/geometry can be created in multiple ways. Describing your process in more detail will help us dictate the best recommendations for you.

CD


#5

I have had this problem in the past , check out this videp

Phil


#6

@lenlenlen1

Did you use the intersect feature in a way similar to what bestistmate’s video shows?


#7

Mine has done the exact same thing and unfortunately I do not know how many saves ago I did the initial intersect but this is happening to me most of the time when I intersect with selection. Random lines everywhere (some hidden) and the faces are just the worst. Can take several goes to try to delete them are just all over the place. Everything looks like a mess :frowning:


#8

I made my model from scratch

P hil


#9

I made my model from scratch entirely, no imports. In the image below the near horizontal edge is a pretty single line, right? Also the near vertical edge looks a bit murky.

Here is the detail view of the knot at bottom. The horizontal edge was a single line originally but it became split and dislocated, and a lot of secondary edges were added up by the system. The original edges were that fantail on the right all nicely gathered on a single point, which I took as the origin for a number of further geometry, using the knot as an End inference. So as I add further geometry using the inferences, or using geometry that is just passing close by, the distortion increases.

The consequence is that if I now wanted to draw an edge using this point as an End, the system might pick any point in the region, and it’s a major irritant having to go back and trying to instill some discipline on a drawing every so often, while being unsure whether this redrawing work will be definitive or not, likely not. Is there any way to prevent or at least minimize this?


#10

you should upload your model in the state prior to the intersection (or whatever it is you’re doing to cause this)… these things are preventable…

it’s seeing the model in the state prior to the additional edges which would be helpful in getting a solution. seeing the results is just confusing as to what you’re doing.


#11

It seems to me I’ve seen some of this behavior after allowing Sketchup to “fix” a model. This happens on save/exit, I think. I’m not saying the auto fix is a bad thing but it’s probably better to identify the problem and repair it yourself or of course, avoid creating the problem in the first place.

Shep


#12

I wouldn’t be surprised to find that this is all a result of working with small geometry.
If you intersect small faces they twist and create unnatural geometry that then needs to be fixed which causes it’s own issues. Then you move the geometry and it drags these hidden tails with it.
Often simply working at a larger scale avoids such problems. But it may be something else.
Without a single model to look at it’s all guess work.


#13

The subject of my screen captures in green is a Messerschmitt Me109, drawn full size. The intent is to create masters for later 3d printing in smaller scale. I was advised here to draw in full size and before printing to make a copy, scale it down and then email to the printers without touching it any further, advice which I found quite good and solved a number of problems. However even drawing in full size I still find instances where I have to go down to details, and these may generate problems like the one illustrated.

3d Warehouse is full of very well executed airplanes, and it SU worked for them then it has to work for me, as simple as that. However it is to be borne in mind that for my intent I need to have a different type of geometry other than outer shells (which most of those are) as my 3d prints have to have physical thickness. Even my physical models wings (30cm span and more) are hollow shells, 1-2mm thick.

On these wings normally I have to “dig” landing gear wells. I drawing these separately, pulling them for depth with an excess to spare, and then I locate these prisms in their appropriate place crossing the wing undersurface (which remember is two shells, remember, inner and outer). That’s when I save the drawing, For an idea of size, a fighter wheel can be some 60-80cm diameter, and a wing chord (breadth) 2-3-4 meters, so we’re not talking of wrist watch making :wink: At this point I save the drawing, take a deep breath, and Intersect the well to the wing geometry!

So this is a relatively simple process, intersecting a 60cm dia cylinder with a slightly curved surface (“curved” meaning a set of adjacent planes of course) and all goes well: I have a nice and clean cut just as expected! Trouble is that after a few sessions I look into the wireframe in the same area and I have a rats nest of extraneous geometries added by SU in the meantime to the original planes intersections, connecting vertexes to other vertexes with no relation at all, and stretching my pretty flat planes into wavy membranes! Why, in all the Olympian gods names, why? :scream:


#14

1mm is where SU starts to think points are coincident, so already we can see problems forming.
Plus SU geometry is a series of straight lines. so when the structure of the geometry isn’t meeting at the joints it tends to distort. You can turn on hidden geometry and move the vertices around for cleaner surfaces. But a lot of clean geometry comes from using similar segmentation on edges to get the mesh to flow evenly and being aware of sharp corners and things, adding a line here and there to relax the mesh. And most definitely avoiding having things as close as 1mm apart. Remember it’s not just the over all structure that need to fit the tolerances, it’s the position of the vertices in 3 dimensions.


#15

[quote=“mmorao, post:13, topic:5876”]
The subject of my screen captures in green is a Messerschmitt Me109, drawn full size. The intent is to create masters for later 3d printing in smaller scale. I was advised here to draw in full size and before printing to make a copy, scale it down and then email to the printers without touching it any further, advice which I found quite good and solved a number of problems. However even drawing in full size I still find instances where I have to go down to details, and these may generate problems like the one illustrated. [/quote]

scaling can reveal the problem… or, if a surface is ever-so-slightly skewed --say, one corner is sloped .001mm out of plane, sketchup may still consider it valid and form a single surface… when you scale that same thing in a direction, the .001mm changes to .01 mm (for example) which is now out of tolerance and sketchup sees it as a problem… it has to triangulate now in order to maintain validity.

however… scaling isn’t the problem. it’s only revealing the problem.

doesn’t matter… or, that requirement is not what’s causing the extra lines to appear.

like above, intersecting is also not the problem… it can only reveal that there’s a problem with one (or more) of the intersecting surfaces… if a corner of a plane is just a tiny bit sloped, sketchup can see it as valid… intersecting geometry through the middle of this not-exactly-perfect plane can steepen the slope in areas at which point sketchup needs to triangulate in order to maintain validity.

said it earlier but to get an actual answer as to why, you’d need to upload a .skp in the state it’s in prior to the extra lines forming… outline what you’re trying to do and any plugins you may be using in the process (for instance, artisan will increase the likelyhood of this stuff happening since it’s moving so many vertices around at varying amounts)… but also as mentioned earlier, this things are preventable… it helps a lot to understand why it happens in the first place because there is a reason for it happening… it’s not random.


#16

Thank you very much for your answers, Box and Jeff, I see a number of points I need to be bear in mind. Coming from the AutoCad universe with 30 years of ingrained habits, I still need to drag myself to a new set of assumptions, and hammer into my head that SU is not ACad :wink:

It feels strange to me that Inferences work in a slightly different way than Esnaps (in ACad one can select which types we want active, but not in SU) and in ACad there is no inkling of this gravity effect where bodies interact with other bodies in proximity, but hockey has different rules from snooker otherwise they would be the same game!

But in any case airplanes being made of complex curves intersecting with other complex curves, there will always be spots where micro-geometries will form, at least with the advice received I’ll have a clearer idea now.

Oh, and my walls are not 1mm thick! As I draw in full size and in the end scale down (1:32) for printing, my walls really are 32mm thick, I am dumb but not that dumb :smile:

Again, thank you very much!
Miguel - Portugal


#17

I too got some of the mystery hidden geometry lines during my first year or so of modeling in SU. But as my experience with creating and manipulating geometry grew, those issues magically disappeared. So you have something to look forward to.

To the original OP, delete the geometry to the left. One possible scenario of why this happened is the misuse of Layers. The geometry off to the left could be on a hidden Layer. In SU, Layers control visibility only. All geometry should be modeled on Layer0. Wrap the model in a Group or Component and place the Group or Component on different Layers to control their visibility.

To avoid mystery hidden lines, take care to do original modeling on Layer0. While modeling, pause ever so briefly to ensure you are seeing the colored cursor clues from the SU inference engine during modeling operations as needed. Sharing the SKP with the forum would allow people to dig into your model which would enable us to find out what is going on instead of just guessing.


#18

No cad import. just Sketchup. Yes, I’m sure I moved the main feature around. I highlight the whole thing and drag where I want it. I’ve been trying a few things to erase those lines, but they wont leave…


#19

I’m pretty sure I did. I get the lines he describes too…


#20

Attach the file to the post so people can examine it.