Strange random lines coming out of nowhere


#1

there is a random line coming out of nowhere and i cannot delete. can someone help me? how can i get rid of them? thank you very much if someone can help me


#2

Are these 'real lines ’ ?
Can they be selected / deleted / erased etc ?
If not, then it might be a Graphics-Card issue.
Are the GC’s drivers up to date.
Have you tried adjusting Preferences > OpenGL settings to see it it improves things.
Have you also tried Model Info > Statistics > Fix Issues…
Also have you used Layers properly ?
That is, all edges and faces should be assigned Layer0, and then ‘collections’ of the geometry is put into a ‘container’ [Groups or Components], which are then assigned their own Layers as desired - used to control visibility - Layers do not separate geometry that is in the same ‘context’ [model or within a 'container] just ‘visibility’…


#3

Can you share the model, as opposed to just an image?


#4

Did you mean “cannot delete”? That would be an important difference.


#5

That file looks like it was imported. Did you happen to use the FreeDXF importer?


#6

They resemble ACT camera frustums, or perhaps sight lines from some shadow study extension ?


#7

I think @jim_foltz has a point. Those lines don’t look like something one would normally create in SketchUp. @billyyyboyyyy where did you get this model? Was it originally created in SketchUp or some other modeling program?


#8

To me this looks like OpenGL artifacts that happen when your model is really far (tens of kilometers or more) from the Sketchup model origin. Was it built on an imported DWG plan or map with the “preserve model origin” option enabled? In this case moving it to the origin, and, perhaps, deleting all extraneous geometry that is outside your actual model area might help.

Anssi


#9

yes im sorry my mistake


#10

i imported it from autocad


#11

It looks like a case of GIGO. Can you open the original file and see about cleaning out the junk?

Or upload the SKP file so we can take a look.


#12

some friends tell me its because of the dual graphics card i have


#13

So ensure that SketchUp [and perhaps all 3d apps ?] is set up to use the ‘good’ GC - i.e. the open with the newest/best OpenGL support etc…


#14

I had a similar thing left over from a component, and that was hidden after nothing of the component remained, it was only visible when orbiting or panning, appearing as a square around it but after stopping moving around it then vanished and could not be clicked upon to select it for deleting.

I’d suggest selecting all the parts of your model without the extraneous lines and copying that to paste in another new file. When you’re happy with the model you have created elsewhere in this way, only really keep the original Acad import as a backup in case it serves any other purpose you have yet to realise.


#15

Let me guess… Using SketchUp Pro, you imported a drawing that you created using a fairly up to date version of AutoCad. You then copied the ‘component’ it created and exploded it so you could extrude the 2D using push/pull into 3D and miracle this is what you’ve got! And I bet if you keep selecting the dodgy lines to try and get to them, half the drawing vanishes with them and worse still you cannot reform the bits you want to keep.
If I am right there is no cure, it is because you thought you imported a 2D drawing but actually you imported a 3D drawing and everything is screwed which you may find hard to believe.
Although this drawing may be terminally ill, there is an easy fix, find a view of your house looking at it between the originally imported AutoCad component and your house. select the house bottom left to top right and select Edit–>Copy. Open another SketchUp and in that window Edit–>Paste in place, all the weird un-editable junk gets left behind.
Its worth a try. I had a similar issue when I imported a tree by mistake from AutoCad,