How does Eneroth's Texture Positioning Tools Work

I just installed Eneroth’s Texture Positioning Tools on my version of SketchUp 2017 Make. While I was trying to become familiar with it, I ran into a couple of issues.

First I cannot get it to do anything on a surface that is not push/pulled. I was hoping to use it to position floor textures. But I do not normally have my floors raised off of the surface, so I do not seem to be able to use this to position the textures.

Also I cannot figure how to use the first two features, Align Texture and Align Texture to Edge. I can see that Align texture is moving my texture, but what exactly is it aligning it to. I cannot seem to get Align Texture to Edge to do anything even if I have an edge selected.

It works for me with textures on an unextruded face. Of course you need to have the texture applied to the face and not a group and the face needs to be selected so the tool knows which texture it needs to be adjusting.

It just will not work for me on an unextruded face and the Align Texture to Edge doesn’t work even on an extruded face. Everything else works fine if the face is extruded. I have tried uninstalling it and installing it again, but both times it will not work on an unextruded face.

Share your .skp file so we can see what you have set up.

Position Texture test.skp (168.0 KB)

This is what I see.

What happens if you use the native tools for positioning the texture?

I can position it just like I always have with the native tools. I can use Eneroth’s Tools on the extruded face, but it will not do anything on the smaller unextruded face. I am wondering if there is a glitch with my system or something.

Sorry. With that style you’re using with the Profiles set to 3 I didn’t see that the small one is the unextruded one. The problem with your unextruded surface is that you’ve applied the texture to the back face. The extension works on front face textures. You shouldn’t be leaving exposed reversed faces or applying textures them anyway.

I’d put it down to a glitch in your modeling process.

Thanks that seemed to be the problem. Somehow my back face material got changed from orange and I didn’t notice. I try to keep it orange because I cannot tell on my computer the difference between the default back and front faces. Do you have any idea of why the Align Texture with Edge is not doing anything. I see it changing things in your gif but it won’t on my computer.

Evidently you picked a different style. Where did you get that style? It’s from ancient versions of SketchUp but hasn’t been included for some time. You can certainly select a new style or edit it.

Are you selecting the face AND the edge?

I have no idea what I did to change the style. I did not realize that it had changed. But I will put it back to what it should be. Thankyou, that was what I was doing wrong with the Align Texture with Edge. I was just selecting an edge not an edge and a line. I knew I was doing something wrong.

You should set up your template with the style as you want it. Also save the style somewhere so you can go back to it later if needed. I have the back face color set to a green I wouldn’t use in normal modeling and I prefer Profiles on but set to 1. I saved the style in with the OEM Default styles so I can retrieve it later if I purged it from the model.

I expect you mean an edge and a face?

Sorted now, though.

I had everything saved in a template. Something happened though and my files are opening without that template. I didn’t even notice until you mentioned the back face. So I will have to make another template if I did not save it somewhere else. First I will have to see if I can figure out why I lost it.

If you start a new file does it show with your preferred style or this one with the yellow selection color and purple back face color? If it opens with your preferred style you don’t need to make a new template. The template style doesn’t necessarily apply to models you’ve already created. They will display with whatever style was used for that model. Changing your template style will have no impact on existing models.

All new are opening with this purple back face style. I did find by backup of my template though so I can change it back.

I figured out what happened. I deleted a bunch of templates that I did not use the other day. Doing this switched the active template. I was able to switch back to My Template and everything is back to normal.

Were you deleting OEM templates?

They were the templates from the list when you start SketchUp. I don’t know if they are OEM or not. There was a forum post a while back, might have been a few weeks ago not a few days. It told how to delete templates that are not used. The post called them stock templates. I deleted a bunch of the ones that I never use, so that the list would be shorter when I search for a particular template.