How do you stop this happening?

Can the ‘dimensions’ box be increased in size so you can, like, actually read the dimensions?


Contrary to what you mentioned in your profile, you are using Sketchup 2023 , right?
This is a bug in SU 2023, typically if you are using high resolution display whit a scale is set more than 100% (In Windows Display settings).
Hope, this will be resolved in upcoming maintenance releases…

1 Like

Profile updated…

Yes, me too.