How Do I Permanently Remove Extensions in Make 2017


I assume this is the correct place to post questions and topics about Make 2017. If not, please move this to the correct location.

I am a new user to SU2017 and downloaded the Pro Trial version months ago. My computer is a Mac with the Sierra OS. I am happy with the Make version, but I can’t find a way to permanently remove two extensions that are for the Pro version only. One is the “Trimble Connect” and the other is the “Advanced Camera Tools”.

When I delete them via the Extension Manager, both disappear from the window and all is right with the world for the current SU session. However, when I open SU the next time, they are back…almost like zombie extensions that won’t die. Again, I delete them and they still keep coming back when I open SU the next time.

How do I permanently remove these two extensions that are useless for Make 2017?

Also, is there a hidden startup selection that allows me to set the size of the window when SU opens? On my 27-inch display, I really don’t want SU taking up the full screen (I know I can resize it after it opens).

Thanks in advance!


You can’t remove them. If you do delete them from the Plugins folder, SketchUp will reinstall them next time it loads. You can disable them in Extension Manager.

As for the window size, one of the Mac gurus will chime in. I set the window size the first time and then did some modeling which I saved. The next time, the window opened at the same size as I last set it.


Unfortunately, disabling them applies only to the current session for me. The next time I open SU, they are back and I receive the same notice telling me I have two extensions to update. This is very annoying.

I even went into the Extension Warehouse while SU was loaded and uninstalled all of the extensions. I attached a screenshot of the notice I received after uninstalling the Advanced Camera Tools. It still loaded the next time I started SU, but now I have a notice that four extensions are ready for updates.




You can update the extensions that need to be updated and you’ll stop getting the message indicating they need to be updated. You cannot permanently remove them and that’s just something you’ll have to accept.It doesn’t make any difference that they are installed since you aren’t going to be using them anyway.


After you set the window the way you want, do SketchUp->Preferences->Workspace and click “Save current window size”.


Thanks, all. These suggestions worked!


This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.