How do I get rid of a 'failed to save file' window?


#1

I’m trying to work on a model that I will use in a video. About every 5 minutes, a window appears that says, “Failed to Save File.” I don’t get the pop-up in other SketchUp sessions. If there’s something corrupt in the file, how do I fix it? I’ve attached the file.
Thanks for the help.
dh
segmented for video.skp (24.9 KB)


#2

This is likely caused by the “AutoSave” feature. Perhaps the path location where the save is attempted, has special permissions ? (Find settings at: Window > Preferences > General > Saving.)

Especially on Windows, I would always suggest save paths that are in the User folder hierarchy. (Such as some sub-folder of “C:/Users/%USERNAME%/Documents”.)

Other things that might interfere with file saving: Anti-Virus, Firewall, etc. Make sure none are blocking or “sandboxing” SketchUp.


#3

Thank you, Dan. Unchecking Autosave seems to have solved the problem


#4

@davidheim1, turning of autosave is not recommended. We need to figure out the cause of auto failure. Where are you saving the model? Please post the full folder path. What is the behavior when you save to desktop?


#5

Dear Yogesh,
Thank you for the reply. The path I was following on my Mac was File>Folder>Folder (the names of the folders aren’t important). The file was in a folder that was itself in a folder on the desktop. When I save the file directly to the desktop, there doesn’t seem to be a problem.
Hope this is clear and helpful.
Best,
dh


#6

@davidheim1, If the folder name has a special characters, such as : ; $ # etc, a bug in SketchUp will cause autosave to fail. If there are any special characters in the folder name please use _ or - instead.


#7

Good to know. I’ll avoid special characters.
Thanks again for your help.
dh


#8

Hi Dan. My SU 15 (on Mac latest OS) has just started saying this. But when I go into Preferences there is no option to direct the autosave into any particular file…so how do I do this? Thanks.


#9

My comments were directed at a MS Windows installation.
I do not have nor use Apple products. Sorry, Elaine, I cannot help you.

Note @yogesh’s tip above about special characters.


Contact SketchUp Pro Technical Support directly:
https://help.sketchup.com/en/contact/technical-support


#10

So far as I know, on Mac there is no way to direct SketchUp to put autosave files in any particular folder.