Hide/Unhide Rest of Components

Hi. This just started happening but has happened to me previously. When I try to go into the wall group to model the walls, the floorplan disappears (turns gray). The floorplan is also a group.Demo.skp (739.1 KB)
Component Edit/Hide rest of model is unchecked. I have it on a toggle (V)but the toggle does not work with the floorplan. Although the floorplan disappears, other components toggle visible and off; it is just the floorplan that remains gray.


Go to Window>Model Info>Components and untick the box(es) for Hide.
Screenshot - 10_9_2021 , 9_05_57 AM

I have a keyboard shortcut established for that because it’s sometimes handy to be able to hide or show the rest of the model in the middle of some operation.

Hi Dave,

I have unchecked Edit/Hide rest of model. It is not working on the floorplan.

Is the floorplan an imported image that you exploded and converted to a texture?

It is an imported image that I exploded and grouped.

I see you have added the SketchUp file and yes, the floor plan is a texture.

Why did you explode the image after importing it? Just import the image and leave it alone. Then it will remain visible when you are editing groups or components.

I exploded it because the floorplan was much larger - it included all apartments on the floor and I only wanted it to be of this particular apartment. I tried to split the image but I could not. Is there a way to split an image file?

Crop the image in an image editor before you import it into SketchUp. Or, since the image should only be temporary, ignore the rest of it and delete it once it’s served its purpose.

It also appears you have reversed it. You can do that in an image editor, too.

Okay. That is a good solution. Why does the texture disappear when I am editing a component? Do all textures disappear when editing components?

Yes. That’s normal behavior. It hides textures outside of the current context so they don’t cause confusion when woking inside a group or component. It’s similar to the other groups and components being faded when editing.

Okay. Thank you so much. I really appreciate your help.

1 Like

You’re quite welcome.

FWIW, if your image is quite large, you might want to crop it in an image editor anyway and then use Large Image Splitter from the Extension Warehouse to split it into smaller sections. This doesn’t crop the image but it helps to improve the resolution of the imported image.

Thank you.

1 Like

Excuse me for butting in here… I have used for ages (11 years !) a program called ‘Image resizer’ to reduce size of photos including material images and then see if the smaller file achieves the desired result. Reduction in file size is significant. It has various settings. There may be other apps that do the same.

Thank you so much. I will try it.

This topic was automatically closed after 186 days. New replies are no longer allowed.