Hidden lines not showing when I export a 2D graphic


#1

I have X-ray checked under Face Style and I can see the hidden lines perfectly fine, but when it comes to exporting it, the PDF of the 2D graphic only shows the visible lines. How can I get the hidden lines to appear in an exported pdf of my drawing?

Edit: for some reason, the hidden lines do show when I export it as a .png file.


#2

I wish I had a solution…I don’t. But I am in the exact same boat. I’ve been exporting several layers for other images then all of a sudden (about three hours ago) SketchUp just decided it would no longer export Hidden Lines w/x ray. I’m getting the same 2D images of surface lines but none of the hidden lines.

I do get the lines as png.file…

Deeply frustrating as my thesis defense is Thursday…and only half of my renderings are done.

Please help…


#3

The PDF or EPS export function in SketchUp produces a pure vector file, with all raster graphics based effects left out, like Sketchy Edges styles, material textures, shadows and hidden lines. That is why they show in raster image exports but not in PDF. The same applies when you print to PDF or a printer using the “Use high-accuracy HLR” (“Raster printing” on a Mac) print option.

To get a vector file with hidden lines you can use LayOut with this workaround:

  • in SketchUp, create two scenes with the same camera view but one
    using the Hidden lines display option and the other Wireframe.
  • Bring the model into LayOut and create two identical views, referring
    to the SketchUp scenes.
  • Align the views, with the wireframe view on top (at this stage you
    can make a copy of the wireframe view outside your page for further
    reference).
  • Explode the wireframe view and set the linetype of the resulting
    group to hidden.
  • Print or export.

Anssi