2D Vector Export Advice Needed


#1

I am relatively new to Sketchup and I would very much appreciate some advise. I have been digging around for hours but I cannot find an ideal solution.

I have a 3D model in Sketchup Pro which I need to export as a various 2D vector graphics.

I manage fine with the PDF and EPS exports keeping the vectors intact but I would like to see if anyone knows of any options to make my life easier.

When I export the model and open it in a vector illustration application, I can see through the model, basically a full wireframe. Is there any way to export this so that the surfaces is opaque but still vector? Basically, so that the vector only contains lines of the edges that can be seen? I have tried layout but it is not really working. Any way to do this direct from Sketchup?

Your help would be much appreciated.


#2

The export result depends on the display style you are using when exporting. The Wireframe and Hidden Line styles both export a wireframe drawing, whereas the other styles substitute your faces with 2D filled polygons.

If you get a full wireframe regardless of the display style you use, the fault lies with the OpenGL support of your display driver software. You might try updating the driver, or, as a workaround, turning off Hardware Acceleration from Window menu>Preferences>OpenGL while exporting. Restarting SketchUp is required before changing the OpenGL settings become effective.

Anssi


#3

Since you have the PRO version, you should have a look at Layout for more export options.


#4

Thanks so much for the reply Anssi.

I am trying to export keeping the vectors intact so exporting as EPS or PDF from Sketchup.

The driver update and the OpenGL recommendation you made has had no effect and when exporting I still see the complete wireframe even though I have tried all display views.

Thanks again!


#5

Thanks Cotty, I followed the Layout route already but the model is complex and although its fine in Sketchup when I take it to Layout I run into problems. The app just doesn’t seem to handle the file when I choose the vector option.


#6

Something is definitely not right, it is not my model as I tried exporting with models from the 3D Warehouse and it even exports these as wireframe, no matter what the setting. I have seen guys export their work just fine using exactly the same settings as what I have been using. I am not sure what to do anymore. It should be working.


#7

Did you try turning off Hardware Acceleration as suggested:

  • go to Window menu>Preferences>OpenGL
  • Uncheck the checkbox “Use Hardware Acceleration”
  • Click OK.
  • Quit SketchUp
  • Reopen SketchUp and retry exporting

If this helps, the fault is with your graphics card driver.

Anssi


#8

Thanks Anssi, I have tried that as you suggested previously and no resolve. I will try that again.


#9

I have once again tried. The Open GL unchecked Use Hardware Acceleration does not have any effect on the output. Is there anything else I can check?


#10

Do you have a small model that, for you, displays this behaviour, and that you could post here as an attachment?

What type is your computer? What kind of graphics card? Is it a laptop with both an Intel graphics chip and an AMD or Nvidia graphics card?

Anssi


#11

Hi Anssi, thanks so much for helping.

I have tried various models, some downloaded from the Sketchup library/3D warehouse and all output the same unwanted full wireframe when exported as 2D vector. So that means that it must be Sketchup or my computer.

I am using a 3 year old macbook pro (intel Core i5) with an intel hd graphics 3000 graphics card. Could that be the problem? I also have the option of using my wife’s macbook (intel core duo) with NVIDIA Geforce Graphics card.

I doubt it, but could it be an installed extension? I have SimLab Step importer installed. Could that be a problem?


#12

On a PC, Intel HD graphics don’t work very well, but reputedly the Mac drivers are better. Have you installed all your available MacOS updates? Also, are you running the most recent maintenance upgrade for your version of SketchUp?

Sometimes erratically working exporters on the Mac version can be fixed by deleting your SketchUp preferences (plist) files. I don’t myself nowadays own a Mac, so I cannot tell you where to locate those.

Anssi


#13

Thanks once again Anssi!

I will give that a shot, I reformatted and re-installed this as my work machine about 3 weeks ago with the latest OS and latest versions of the software. So everything should be up to date.

I am running out of time, so I really hope I can get this working soon.


#14

Anssi,

I tried the plist etc. as you suggested but it didnt make a difference. I was getting desperate so I installed Sketchup on my wife’s Macbook and the export now works perfectly!

It still doesn’t work on my machine.

What I am thinking is that there must be some conflict between Sketchup and other 3D applications on my machine.

Not sure exactly what it is but I am happy I can now get it working since I already wasted a ton of time troubleshooting it.

Thanks for the help!